HDU1018——Big Number

20 篇文章 0 订阅

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34866    Accepted Submission(s): 16552



Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

解:题目中要求得到N的阶乘的位数,位数就会联想到使用log10进行求解。而log10(5*6)=log10(5)+log10(6),因此不需要求得阶乘最终解,而且根据数据量,只需要一遍循环,做加法即可。

#include<stdio.h>
#include<math.h>

int main()
{
	long long n;
	long long x;
	scanf("%I64d",&n);
	while(n--){
		double count=0.0;
		scanf("%I64d",&x);
		for(double i=2;i<=x;i++){
			count+=log10(i);
		}
		printf("%I64d\n",(long long)(count+1));
	}
	
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值