POJ1852——Ants

18 篇文章 0 订阅
10 篇文章 0 订阅
Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16957 Accepted: 7262

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source


题意:

n只蚂蚁,在长度为l的杆子上,起始位置为x[i]向两端爬行,每分钟爬行1,爬行的方向不一定,求所有蚂蚁爬下杆子的最大时间和最小时间。

解:

当所有蚂蚁向离杆子最近方向爬时为最小时间,此时不会相遇,此时所有离杆子近的距离中的最大距离为最小时间

当所有蚂蚁向离杆子最远方向爬时为最大时间,此时如果相遇,蚂蚁会掉头可以假设为交错爬行,此时最大距离为最大时间。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int x[1000005];

int main()
{
	int t;
	while(~scanf("%d",&t))
	{
		int n,l;
		int minx,maxx;
		while(t--)
		{
			memset(x,0,sizeof(x));
			minx=0;
			maxx=0;
			scanf("%d %d",&l,&n);
			for(int i=0;i<n;i++)
				scanf("%d",&x[i]);
			for(int i=0;i<n;i++)
			{
				minx=max(minx,min(x[i],l-x[i]));
				maxx=max(maxx,max(x[i],l-x[i]));
			}
			printf("%d %d\n",minx,maxx);
		}
	}
	return 0;
 } 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值