POJ3617——Best Cow Line

14 篇文章 0 订阅
Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22772 Accepted: 6207

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source



题意:

给定一个字符串,将其重新排列,组成一个字典序尽量小的字符串,重新排列的方式为:原字符串的两端字符比较,较小的一个放到新字符串的开头。


解:

贪心解决,两端开始扫描,找寻较小的字符,如果相同则比较下一个字母,当不同时输出较小一侧的字符。


#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char str[2005];

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int count=0;
		memset(str,0,sizeof(str));
		for(int i=0;i<n;i++)
		{
			cin>>str[i];
		}
		int a,b;
		a=0;b=n-1;
		while(a<=b)
		{
			int flag=0;
			for(int i=0;a+i<=b;i++)
			{
				if(str[a+i]<str[b-i])
				{
					flag=1;
					break;
				}
				if(str[a+i]>str[b-i])
				{
					flag=0;
					break;
				}
			}
			if(flag)
				printf("%c",str[a++]);
			else
				printf("%c",str[b--]);
			count++;
			if(count%80==0)
			printf("\n");
		}	
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值