【poj1101】The Game BFS

Description

One morning, you wake up and think: “I am such a good programmer. Why not make some money?” So you decide to write a computer game.
The game takes place on a rectangular board consisting of w * h squares. Each square might or might not contain a game piece, as shown in the picture.

One important aspect of the game is whether two game pieces can be connected by a path which satisfies the two following properties:

It consists of straight segments, each one being either horizontal or vertical.

It does not cross any other game pieces.

(It is allowed that the path leaves the board temporarily.)

Here is an example:
这里写图片描述

The game pieces at (1,3) and at (4, 4) can be connected. The game pieces at (2, 3) and (3, 4) cannot be connected; each path would cross at least one other game piece.

The part of the game you have to write now is the one testing whether two game pieces can be connected according to the rules above.

Input

The input contains descriptions of several different game situations. The first line of each description contains two integers w and h (1 <= w,h <= 75), the width and the height of the board. The next h lines describe the contents of the board; each of these lines contains exactly w characters: a “X” if there is a game piece at this location, and a space if there is no game piece.

Each description is followed by several lines containing four integers x1, y1, x2, y2 each satisfying 1 <= x1,x2 <= w, 1 <= y1,y2 <= h. These are the coordinates of two game pieces. (The upper left corner has the coordinates (1, 1).) These two game pieces will always be different. The list of pairs of game pieces for a board will be terminated by a line containing “0 0 0 0”.

The entire input is terminated by a test case starting with w=h=0. This test case should not be procesed.

Output

For each board, output the line “Board #n:”, where n is the number of the board. Then, output one line for each pair of game pieces associated with the board description. Each of these lines has to start with “Pair m: “, where m is the number of the pair (starting the count with 1 for each board). Follow this by “ksegments.”, where k is the minimum number of segments for a path connecting the two game pieces, or “impossible.”, if it is not possible to connect the two game pieces as described above.

Output a blank line after each board.

Sample Input

5 4
XXXXX
X   X
XXX X
 XXX 
2 3 5 3
1 3 4 4
2 3 3 4
0 0 0 0
0 0

Sample Output

Board #1:
Pair 1: 4 segments.
Pair 2: 3 segments.
Pair 3: impossible.

Source

Mid-Central European Regional Contest 1999


去年八月份做过类似的,但当时直接用错误方法水过去了……现在搞明白了

题意:问两个格子以连连看的方式相连,最少用多少直线段。
(那个题是最少拐几个弯)

想到一个堆+bfs的方法:优先拓展直线段少的

显然不对(但能A,数据水)

因为要求拐的少,所以就认准一个方向走就行了,把沿途的格子丢进队列里,连堆都不用。这样能保证拓展的点的答案递增,可以bfs

一个小技巧而已吧…

【NOIP题真清新啊

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;

typedef long long LL;
const int SZ = 1010;
const int INF = 1000000010;

const int dx[] = {0,1,0,-1};
const int dy[] = {-1,0,1,0};

int n,m;
char maps[SZ][SZ]; 
bool vis[SZ][SZ];

struct node
{
    int x,y,d,cnt;
};

//bool operator <(node a,node b) { return a.cnt > b.cnt; }

queue<node> q;

bool is_can(int x,int y) { return x >= 0 && x <= n + 1 && y >= 0 && y <= m + 1; }

int ask_ans(int sx,int sy,int ex,int ey)
{
    memset(vis,0,sizeof(vis));
    while(q.size()) q.pop();
    vis[sx][sy] = 1;
    q.push((node){sx,sy,-1,0});
    while(q.size())
    {
        node f = q.front(); q.pop();
//      cout << f.x << " " << f.y << " " << maps[f.x][f.y] << endl;
        for(int i = 0;i < 4;i ++)
        {
            int x = f.x + dx[i];
            int y = f.y + dy[i];
            while(is_can(x,y))
            {
                if(x == ex && y == ey) return i == f.d ? f.cnt : f.cnt + 1;
                if(maps[x][y] == 'X') break;
                if(is_can(x,y) && maps[x][y] != 'X' && !vis[x][y])
                    q.push((node){x,y,i,i == f.d ? f.cnt : f.cnt + 1}),vis[x][y] = 1;
                x += dx[i], y += dy[i];
            }
        }   
    }
    return -1;
}

int main()
{
    int Case = 0; 
    while(~scanf("%d%d",&m,&n) && n && m)
    {
        memset(maps,0,sizeof(maps));
        getchar();
        for(int i = 1;i <= n;i ++)
            gets(maps[i] + 1);
        int x1,y1,x2,y2,tot = 0;
        printf("Board #%d:\n",++ Case);
        while(scanf("%d%d%d%d",&y1,&x1,&y2,&x2) && x1 && y1 && x2 && y2)
        {
            int ans = ask_ans(x1,y1,x2,y2);
            if(~ans)
                printf("Pair %d: %d segments.\n",++ tot,ans);
            else
                printf("Pair %d: impossible.\n",++ tot);
        }
        puts("");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值