大数问题

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

这道题的解题思路很明确即用字符串,用字符串输入两个字符串,分别减去‘0’,逆序转化为两个整型数组,输出时再逆序输出即可。很简单的一道题,直接上代码!

#include<stdio.h>      
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;
int main(){
	int t,u=1;
	scanf("%d",&t);
	while(t--){
	char laa[1000],lbb[1000];    //定义两个存放字符串的字符数组 
	int a[1000],b[1000],c[1000];  //存储相应的字符串转化为对应的十进制数 
	memset(a,0,sizeof(a));
	memset(b,0,sizeof(b));
	memset(c,0,sizeof(c));
	scanf("%s%s",laa,lbb);
	int l=strlen(laa);
	int k=strlen(lbb);
	int m=0,j;
	j=0;
	for(int i=l-1;i>=0;i--){
		a[m]=laa[i]-'0';
		m++;
	}
	j=0;
	m=0;
	for(int i=k-1;i>=0;i--){
		b[m]=lbb[i]-'0';
		m++;
	}
	int p,r=0;
	int t=max(l,k);   //取对应的l,k中的最大值 
	for(int i=0;i<t;i++){   //对进位的处理 
		p=a[i]+b[i]+r;
		r=p/10;
		c[i]=p%10;
	}
	if(r){         //这一步的作用是判断逆序后的 
		c[t++]++;   //两个数组最后一位相加后的结果是否为1 
	}
	printf("Case %d:\n",u++);
	printf("%s + %s = ",laa,lbb);
	for(int s=t-1;s>=0;s--){
		printf("%d",c[s]);
	}
	printf("\n");
  }
	return 0;
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值