Instrction Arrangement

Ali has taken the Computer Organization and Architecture course this term. He learned that there may be dependence between instructions, like WAR (write after read), WAW, RAW. 
If the distance between two instructions is less than the Safe Distance, it will result in hazard, which may cause wrong result. So we need to design special circuit to eliminate hazard. However the most simple way to solve this problem is to add bubbles (useless operation), which means wasting time to ensure that the distance between two instructions is not smaller than the Safe Distance. 
The definition of the distance between two instructions is the difference between their beginning times. 
Now we have many instructions, and we know the dependent relations and Safe Distances between instructions. We also have a very strong CPU with infinite number of cores, so you can run as many instructions as you want simultaneity, and the CPU is so fast that it just cost 1ns to finish any instruction. 
Your job is to rearrange the instructions so that the CPU can finish all the instructions using minimum time.
Input
The input consists several testcases. 
The first line has two integers N, M (N <= 1000, M <= 10000), means that there are N instructions and M dependent relations. 
The following M lines, each contains three integers X, Y , Z, means the Safe Distance between X and Y is Z, and Y should run after X. The instructions are numbered from 0 to N - 1. 
Output
Print one integer, the minimum time the CPU needs to run. 
Sample Input
5 2
1 2 1
3 4 1
Sample Output
2

        
  
Hint
In the 1st ns, instruction 0, 1 and 3 are executed;
In the 2nd ns, instruction 2 and 4 are executed.
So the answer should be 2.


题意:cpu每执行一个命令需1ns,给出n个命令,m个命令之间的间隔,求cpu执行完所有的命令的最短时间。

思路:拓扑排序, 然后dp求解最短时间


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=1005;
int n, m;
int dp[maxn];
int du[maxn];
int cost[maxn][maxn];
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        memset(dp, 0, sizeof(dp));
        memset(du, 0, sizeof(du));
        memset(cost, 0, sizeof(cost));
        queue<int> q;
        int x, y, z;
        for(int i=0; i<m; i++)       //建图
        {
            scanf("%d%d%d", &x, &y, &z);
            cost[y][x]=z;
            du[y]++;          
        }
        for(int i=0; i<n; i++)   //将入度为0的操作设为1
        {
            if(du[i]==0)
            {
                 q.push(i);
                 dp[i]=1;
            }
        }
        while(!q.empty())
        {
            int x=q.front();
            q.pop();
            for(int i=0; i<n; i++)
            {
                if(cost[i][x]!=0)
                {
                    dp[i]=max(dp[i], dp[x]+cost[i][x]);
                    du[i]--; 
                    cost[i][x]=0;
                    if(du[i]==0)
                        q.push(i);
                }
            }
        }
        int ans=0;
        for(int i=0; i<n; i++)
            ans=max(ans, dp[i]);
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值