HDU 5573 Binary Tree (思维+构造)

Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

⋅ 1≤T≤100.

⋅ 1≤N≤109.

⋅ N≤2K≤260.

Output
For every test case, you should output “Case #x:” first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as ‘a b’, where a is node label of the node the frog visited, and b is either ‘+’ or ‘-’ which means he increases / decreases his number by a.

It’s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input
2
5 3
10 4

Sample Output
Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +

题意: 在一颗满二叉树上,对于节点x,左儿子、右儿子分别为2x 2x+1,那么,从根节点出发,可以加上或减去当前节点值,使得到达第K层时,sum = n;

思路: 我们可以得知,1+2+4+8+…+2 ^ k = 2 ^ (k+1)-1,并且,通过改变其加减符号,我们可以得到2 ^ (k+1)内的任意奇数。那么,通过奇数+1的方式即可得到任意偶数。
因此,我们可以判断n为奇数,或者为偶数。当为奇数时,我们从高位开始枚举,sum = 2 ^ (k-1),判断sum与n的大小关系,若sum > n,则下一位为-,否在为+;并且记录sum,以此类推。若n为偶数,则2 ^ (k-1)+1即可。

#include<bits/stdc++.h>
using namespace std;
#define ll long long
int main()
{
    int T,cas = 0;
    cin>>T;
    while(T--){
        cout<<"Case #"<<++cas<<":"<<endl;
        ll n,k;
        ll a[70],cnt = 0;
        cin>>n>>k;
        if(n&1) a[++cnt] = (1ll*1<<k-1);
        else a[++cnt] = (1ll*1<<k-1)+1,n--;
        ll sum = (1ll*1<<k-1);
        for(int i = k-2; i >= 0; i--){
            if(sum > n){
                a[++cnt] = -(1ll*1<<i);
                sum -= (1ll*1<<i);
            }
            else if(sum < n){
                a[++cnt] = (1ll*1<<i);
                sum += (1ll*1<<i);
            }
        }
        for(int i = cnt; i >=1; i--){
            if(a[i] < 0)    printf("%lld -\n",-a[i]);
            else    printf("%lld +\n",a[i]);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值