UVA 10168 Summation of Four Primes(数论)

Summation of Four Primes

Input: standard input

Output: standard output

Time Limit: 4 seconds

Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.

Input

The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.

Output

For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.

Sample Input:

24
36
46

Sample Output:

3 11 3 7
3 7 13 13
11 11 17 7

题意:给出一个整数n,能否找出四个素数使得它们的和恰好是n,如果找不到,输出 “Impssible.";

分析:因为最小的素数是2,所以当n<8时无解;又一个偶数可以写成两个素数的和,所以当n>=8时,可以先把n变成一个偶数,然后找两个素数使得它们的和恰好是那个偶数即可。

#include<stdio.h>
#include<string.h>
const int MAXN = 10000005;
int vis[MAXN], prime[700000], num;

void get_prime()
{
    num = 0;
    memset(vis, 0, sizeof(vis));
    vis[0] = vis[1] = 1;
    for(int i = 2; i < MAXN; i++)
    {
        if(!vis[i])
        {
            prime[num++] = i;
            for(int j = i + i; j < MAXN; j += i)
                vis[j] = 1;
        }
    }
}

int main()
{
    int n;
    get_prime();
    while(~scanf("%d",&n)) {
        if(n < 8) {
            printf("Impossible.\n");
            continue;
        }
        if(n&1) {
            printf("2 3 ");
            n -= 5;
        }
        else {
            printf("2 2 ");
            n -= 4;
        }  //n已变成偶数,找两个素数使得它们的和恰好是n
        for(int i = 0; i < num; i++)
            if(!vis[n-prime[i]]) {
                printf("%d %d\n", prime[i], n-prime[i]);
                break;
            }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值