hdu1829 A Bug's Life --分组并查集

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1829


一:原题内容

Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 
Sample Output
 
 
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.

二:分析理解

教授正在探求一种小虫是不是异性交配,没有同性交配。

n个小虫,分为雌雄,编号从1到n,现给定m对关系a,b,表示编号a和b可以交配(异性),问是否会出现矛盾?也就是下例:

1 2

2 3

1 3

出现矛盾,2与3是同性交配了。


三:AC代码

#include<iostream>    
#include<string.h>  
#include<algorithm>  

using namespace std;

int pre[2015];
int sex[2015];
bool flag;
int T;
int n, m;
int a, b;

int FindRoot(int x)
{
	if (x != pre[x])
		pre[x] = FindRoot(pre[x]);

	return pre[x];
}

void Union(int x, int y)
{
	int x_root = FindRoot(x);
	int y_root = FindRoot(y);

	if (x_root != y_root)
		pre[x_root] = y_root;
}

int main()
{
	scanf("%d", &T);

	for (int cas = 1; cas <= T; cas++)
	{
		scanf("%d%d", &n, &m);

		memset(sex, 0, sizeof(sex));
		for (int i = 1; i < 2005; i++)
			pre[i] = i;
		flag = 0;

		while (m--)
		{
			scanf("%d%d", &a, &b);

			if (flag) continue;//教授的假设已经失败,无需再做
			if (FindRoot(a) == FindRoot(b)) { flag = 1; continue; }

			if (sex[a] == 0)
				sex[a] = b;
			else
				Union(sex[a], b);

			if (sex[b] == 0)
				sex[b] = a;
			else
				Union(sex[b], a);
		}

		printf("Scenario #%d:\n", cas);
		if (flag)
			printf("Suspicious bugs found!\n");
		else
			printf("No suspicious bugs found!\n");

		printf("\n");
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值