poj 1012 Joseph

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5

30

因为上限是13,所以直接遍历,打表;

因此要找到递推式;

考虑k=i,第j轮的时候

假设上次被排除的是temp【j-1】,那么就会重新编号,下一个就是计数的第一个;

现在一共有2*i-j+1个,之后的第m个是(temp[j-1]+m-1)%(2*i-j+1);

以此得到递推就可以解决题目了(我都觉得没讲清楚)

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int ans[14]={0};
    int temp[50]={0};
    //打表
    for(int i=1;i<14;++i)
    {
        int m=1;
        for(int j=1;j<=i;++j)
        {
            //递推式
            temp[j]=(temp[j-1]+m-1)%(2*i-j+1);
            if(temp[j]<i)
            {
                j=0;
                ++m;
            }
        }
        ans[i]=m;
    }
    int k;
    while(scanf("%d",&k)!=EOF&&k!=0)
    {
            cout<<ans[k]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值