poj 2253 Frogger

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33256 Accepted: 10682

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.  
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.  
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.  
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.  

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.  

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source


这道题的题意就是找到起点到终点所有通路中的一条,这条通路满足所有步中的最大值,比其他通路中所有步中的最大值小;这道题可以套dijkstra的模板,只要把松弛操作修改一下就可以了,即是 if(max(dis[x],edge[x][j])<dis[j])

               dis[j]=max(dis[x],edge[x][j]);


#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#include<set>
#define pi 3.14159265358979323846
using namespace std;
const int inf=0x3f3f3f3f;
int n;
int x[201];
int y[201];
int dis[201];
int edge[201][201];
int distance(int x,int y,int a,int b)
{
    return (x-a)*(x-a)+(y-b)*(y-b);
}
bool vis[201];
int dijkstra()
{
    int ans=0;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;++i)
        dis[i]=edge[1][i];
    for(int i=1;i<=n;++i)
    {
        int x,m=inf;
        for(int j=1;j<=n;++j)
        {
            if(!vis[j]&&dis[j]<=m)
                m=dis[x=j];
        }
        vis[x]=1;
        ans=max(ans,m);
        for(int j=1;j<=n;++j)
        {
            if(max(dis[x],edge[x][j])<dis[j])
                dis[j]=max(dis[x],edge[x][j]);
        }
    }
    return dis[2];
}
int main()
{
    int cnt=0;
    while(scanf("%d",&n)!=EOF&&n)
    {
        ++cnt;
        memset(edge,0,sizeof(edge));
        for(int i=1;i<=n;++i)
        {
            scanf("%d %d",&x[i],&y[i]);
            for(int j=1;j<=i;++j)
            {
                if(edge[i][j]==0)
                    edge[i][j]=edge[j][i]=distance(x[i],y[i],x[j],y[j]);
            }
        }

        double ans;
        ans=sqrt((double)dijkstra());
        printf("Scenario #%d\n",cnt);
        printf("Frog Distance = %.3lf\n\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值