HDU 6130 Kolakoski数列

17 篇文章 0 订阅

Kolakoski

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 639    Accepted Submission(s): 316


Problem Description
This is Kolakosiki sequence:  1,2,2,1,1,2,1,2,2,1,2,2,1,1,2,1,1,2,2,1 . This sequence consists of  1  and  2 , and its first term equals  1 . Besides, if you see adjacent and equal terms as one group, you will get  1,22,11,2,1,22,1,22,11,2,11,22,1 . Count number of terms in every group, you will get the sequence itself. Now, the sequence can be uniquely determined. Please tell HazelFan its  n th element.
 

Input
The first line contains a positive integer  T(1T5) , denoting the number of test cases.
For each test case:
A single line contains a positive integer  n(1n107) .
 

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
 

Sample Input
  
  
2 1 2
 

Sample Output
  
  
1 2
 

Source
 
就是Kolakoshi数列 规律是  a[1] = 2 则后面是两个相同的数 2 2 ,于是 a[1] = a[2] = 2;
由因为a[2] = 2,所以 a[3] = a[4] = 1,由于 a[3] = 1,所以a[5] = 2 以此类推
暴力打表就好了
#include <bits/stdc++.h>
using namespace std;

#define maxn 10000000
int a[maxn + 10];
void init(){
	a[0] = 1;
	a[1] = 2;
	a[2] = 2;
	int cnt = 3;
	int flag = 1, ans = 2;
	for(int i = 2;cnt <= maxn + 5;i++){
		ans += flag * (-1);
		flag *= -1;
		for(int j = 1;j <= a[i];j++){
			a[cnt++] = ans;
		}
	}
}
int main(){
	int t;
	cin >> t;
	while(t--){
		int n;
		cin >> n;
		cout << a[n - 1] << endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值