数据结构实验之排序一:一趟快排

数据结构实验之排序一:一趟快排

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

给定N个长整型范围内的整数,要求输出以给定数据中第一个数为枢轴进行一趟快速排序之后的结果。

 
Input
连续输入多组数据,每组输入数据第一行给出正整数N(N < = 10^5),随后给出N个长整型范围内的整数,数字间以空格分隔。
Output

输出一趟快速排序后的结果,数字间以一个空格间隔,行末不得有多余空格。

Example Input
8
49 38 65 97 76 13 27 49
Example Output
27 38 13 49 76 97 65 49
#include<iostream>
#include<stdio.h>
#include<malloc.h>
#define MAXSIZE 100001
typedef struct{
	int key;
}RedType;
typedef struct {
	RedType r[MAXSIZE+1];
	int length;
}Sqlist;
int pivotkey;

int Partiton(Sqlist &L,int low,int high)
{
	L.r[0]=L.r[low];
	pivotkey=L.r[low].key;
	while(low<high)
	{
		while(low<high && L.r[high].key >=pivotkey)
		--high;
		L.r[low]=L.r[high];
		while(low<high && L.r[low].key <=pivotkey)
		++low;
		L.r[high]=L.r[low];
	}
	L.r[low]=L.r[0];
	return low;
}
int main()
{
	Sqlist L;
	while(~scanf("%d",&L.length))
	{
	
//	cin>>L.length;
	for(int i=1;i<=L.length;i++)
	{
	//	cin>>L.r[i];
		scanf("%d",&L.r[i].key);
	}
    Partiton(L,1,L.length);
	for(int i=1;i<L.length;i++)
	{
		printf("%d ",L.r[i].key);

	}
		printf("%d\n",L.r[L.length].key);
	}
	return 0;
	
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值