uva 11463 Commandos

A group of commandos were assigned a critical task. They are to destroy an enemy head quarter. The enemy head quarter consists of several buildings and the buildings are connected by roads. The commandos must visit each building and place a bomb at the base of each building. They start their mission at the base of a particular building and from there they disseminate to reach each building. The commandos must use the available roads to travel between buildings. Any of them can visit one building after another, but they must all gather at a common place when their task in done. In this problem, you will be given the description of different enemy headquarters. Your job is to determine the minimum time needed to complete the mission. Each commando takes exactly one unit of time to move between buildings. You may assume that the time required to place a bomb is negligible. Each commando can carry unlimited number of bombs and there is an unlimited supply of commando troops for the mission.

Input
Input starts with an integer T (≤50), denoting the number of test cases.

The first line of each case starts with a positive integer N (1 ≤ N ≤ 100), where N denotes the number of buildings in the head quarter. The next line contains a positive integer R, where R is the number of roads connecting two buildings. Each of the next R lines contain two distinct numbers u v (0 ≤ u, v < N), this means there is a road connecting building u to building v. The buildings are numbered from 0 to N-1. The last line of each case contains two integers s d (0 ≤ s, d < N). Where s denotes the building from where the mission starts and d denotes the building where they must meet. You may assume that two buildings will be directly connected by at most one road. The input will be given such that, it will be possible to go from any building to another by using one or more roads.

Output
For each case, print the case number and the minimum time required to complete the mission.

Sample Input
2
4
3
0 1
2 1
1 3
0 3
2
1
0 1
1 0
Sample Output
Case 1: 4
Case 2: 1

题目:有一个敢死队,要摧毁一群建筑,他们从一个特定的建筑出发,最后到一个特定的建筑集合;

        现在给你各个建筑之间的连接路线,在建筑中穿梭需要1个单位时间,问集合的最早时间。

分析:图论,最短路径。直接计算起点s和终点e到那个其他所有点的最短路径;
floyd比较简单 也可以用两个dijk 因为数据小。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 101000;
#define inf 0x3f3f3f3f
int d[200];
int s[200];
int e[200][200];
int main()
{
    int t;
    cin>>t;
    int cc=1;
    while(t--)
    {
        int n,m;
        cin>>n>>m;
        memset(e,0x3f,sizeof(e));
                for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                e[i][j]=inf;
            e[i][i]=0;
        }
        for(int i=0;i<m;i++)
        {
            int a,b;
            cin>>a>>b;
            e[a][b]=1;
            e[b][a]=1;
        }
        int si,di;
        cin>>si>>di;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                for(int k=0;k<n;k++)
                    {
                        if(e[j][k]>e[j][i]+e[i][k])
                            e[j][k]=e[j][i]+e[i][k];
                    }
        int maxx=0;
        for(int i=0;i<n;i++)
            maxx=max(e[si][i]+e[i][di],maxx);
        printf("Case %d: %d\n",cc++,maxx);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值