PAT Pop Sequence

02-3. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO 

题目大意:
       有一个大小为M的栈和一个大小为N的以1为首的升序序列,判断能否利用这个栈将该数组的顺序变成与输入数组相同的顺序,输入的数据有K组。例如:如果M = 5,N = 7,我们可以利用栈得到1,2,3,4,5,6,7,但是不能得到3,2,1,7,5,6,4。如果能得到输入的序列,则输出YES,否则输出NO。

思路:
       可以将栈想做中转站,若想使序列从A到B,必须经过有限大的C,如图所示:


如果A[i]和B[j]相等并且C没有满,则判断A的下一位和B的下一位,如果A[i]和B[j]不相等并且C未满,则将A[i]囤积到C,直到C的最上面元素与B[j]相等,取出C的top,如此循环。
#include <cstdio>
#include <stack>
using namespace std;
const int maxn = 1000;


int main()
{
	int m, n, k;
	int arr[maxn];
	scanf("%d%d%d", &m, &n, &k);
	for(int i = 0; i < k; i++)
	{
		int A = 1, B = 0;
		int ok = 1;
		stack<int> s;
		for(int j = 0; j < n; j++)
		{
			scanf("%d", &arr[j]);
		}
		while(B < n)
		{
			if(A == arr[B] && s.size() < m)
			{
				A++;
				B++;	
			}	
			else if(!s.empty() && s.top() == arr[B])
			{
				s.pop();
				B++;	
			} 
			else if(A <= n && s.size() < m)
			{
				s.push(A);
				A++;
			}
			else
			{
				ok = 0;
				break;
			}
		}
		printf("%s\n", ok ? "YES" : "NO");
	}
	return 0;
}</span>




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值