D - Vacation

44 篇文章 0 订阅
5 篇文章 0 订阅

链接:https://vjudge.net/contest/381756#problem/D

Tom and Jerry are going on a vacation. They are now driving on a one-way road and several cars are in front of them. To be more specific, there are nn cars in front of them. The iith car has a length of lili, the head of it is sisi from the stop-line, and its maximum velocity is vivi. The car Tom and Jerry are driving is l0l0 in length, and s0s0 from the stop-line, with a maximum velocity of v0v0.
The traffic light has a very long cycle. You can assume that it is always green light. However, since the road is too narrow, no car can get ahead of other cars. Even if your speed can be greater than the car in front of you, you still can only drive at the same speed as the anterior car. But when not affected by the car ahead, the driver will drive at the maximum speed. You can assume that every driver here is very good at driving, so that the distance of adjacent cars can be kept to be 00.
Though Tom and Jerry know that they can pass the stop-line during green light, they still want to know the minimum time they need to pass the stop-line. We say a car passes the stop-line once the head of the car passes it.
Please notice that even after a car passes the stop-line, it still runs on the road, and cannot be overtaken.

Input

This problem contains multiple test cases.
For each test case, the first line contains an integer nn (1≤n≤105,∑n≤2×1061≤n≤105,∑n≤2×106), the number of cars.
The next three lines each contains n+1n+1 integers, li,si,vili,si,vi (1≤si,vi,li≤1091≤si,vi,li≤109). It's guaranteed that si≥si+1+li+1,∀i∈[0,n−1]si≥si+1+li+1,∀i∈[0,n−1]

Output

For each test case, output one line containing the answer. Your answer will be accepted if its absolute or relative error does not exceed 10−610−6.
Formally, let your answer be aa, and the jury's answer is bb. Your answer is considered correct if |a−b|max(1,|b|)≤10−6|a−b|max(1,|b|)≤10−6.
The answer is guaranteed to exist.

Sample Input

1
2 2
7 1
2 1
2
1 2 2
10 7 1
6 2 1

Sample Output

3.5000000000
5.0000000000

Sponsor

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
double eps=1e-6;
struct node{
    int l,s,v;
    double t;
}x[100001];
int n;
bool check(double p)
{
    double ans=x[n].s*1.0-x[n].v*p;
    for(int i=n-1;i>=0;i--)
    {
        if(x[i].s-x[i].v*p<=ans+x[i+1].l)
            ans+=x[i+1].l;
        else
            ans=x[i].s-x[i].v*p;
    }
    return ans<=eps;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
        {
            scanf("%d",&x[i].l);
        }
        for(int i=0;i<=n;i++)
        {
            scanf("%d",&x[i].s);
        }
        for(int i=0;i<=n;i++)
        {
            scanf("%d",&x[i].v);
        }
        double l=0,r=1e18;
        while(r-l>eps)
        {
            double mid=(l+r)/2;
            if(check(mid))
                r=mid;
            else
            l=mid;
        }
        printf("%.10lf\n",r);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值