The Accomodation of Students

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other. 

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room. 

Calculate the maximum number of pairs that can be arranged into these double rooms. 

Input

For each data set: 
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs. 

Proceed to the end of file. 
 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms. 

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No
3

题目意思为有一些人,有的人相互认识,问能不能通过两两配对来进行开房间,如果可以输出需要的房间数,否则输出No。不可以的情况为当图不是二分图的情况,可以通过bfs染色来判断,即从其中一个顶点开始,将跟它邻接的点染成与其不同的颜色,如果邻接的点有相同颜色的,则说明不是二分图,每次用bfs遍历即可。如果是二分图可以跑一遍匈牙利算法求出答案。

AC代码:

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<vector>
#include<queue>
#define mem(a, b) memset(a, b, sizeof(a))
using namespace std;
const int maxn = 220;
vector<int>G[maxn];
queue<int>q;
int vis[maxn], line[maxn], color[maxn];

void init()
{
    for(int i = 0; i < maxn; i++)
    {
        G[i].clear();
    }
    mem(line, 0);
    mem(vis, 0);
    mem(color, 0);
}
bool bfs(int s)
{
    while(!q.empty())
    {
        q.pop();
    }
    q.push(s);
    color[s] = 1;
    while(!q.empty())
    {
        int temp = q.front();
        q.pop();
        for(int i = 0; i < G[temp].size(); i++)
        {
            if(!vis[G[temp][i]])
            {
                vis[G[temp][i]] = 1;
                color[G[temp][i]] = -color[temp];
                q.push(G[temp][i]);
            }
            else
            {
                if(color[temp] == color[G[temp][i]])
                {
                    return false;
                }
            }
        }
    }
    return true;
}

bool find_path(int x)
{
    for(int i = 0; i < G[x].size(); i++)
    {
        if(!vis[G[x][i]])
        {
            vis[G[x][i]] = 1;
            if(!line[G[x][i]] || find_path(line[G[x][i]]))
            {
                line[G[x][i]] = x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    int n, m;
    ios::sync_with_stdio(false);
    while(cin >> n >> m)
    {
        init();
        for(int i = 1; i <= m; ++ i)
        {
            int a, b;
            cin >> a >> b;
            G[a].push_back(b);
            G[b].push_back(a);
        }
        if(!bfs(1))
        {
            cout << "No" << endl;
        }
        else
        {
            int ans = 1;
            for(int i = 1; i <= n; ++ i)
            {
                mem(vis, 0);
                if(find_path(i))
                {
                    ans++;
                }
            }
            cout << ans/2 << endl;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值