hdu--2576

Description

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down. 
 

Input

The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10). 
The next r line is the map’s description.
 

Output

For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input

    
    
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output

    
    
7
 

解题思路:和迷宫题类似,题目大意为从Y出发是否能走到G的位置,如果可以输出最少时间,否则输出 Please give me another chance!,但注意的时,当走到石头的地方时间为k的倍数时,是可以通过的,否则不能通过。对于Bfs题目最难的就是什么时候该标记的问题,这里只有当走过的地方为K的倍数时,才标记。

提供一组测试数据:
2 4 5
..Y#
.##G

6

代码如下:
#include<stdio.h>
#include<queue>
#include<string.h>
#define INF 0x3f3f3f3f
using namespace std;
int n,m,k;
char mark[110][110];
int vist[110][110];
int dis[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
int ans;
struct stu
{
	int x,y,t;
};
stu s,e;
void bfs()
{
	memset(vist,0,sizeof(vist));
	//vist[s.x][s.y]=1;
	stu temp;
	stu vt;
	queue<stu>q;
	while(!q.empty())
	{
		q.pop();
	}
	q.push(s);
	while(!q.empty())
	{
		vt=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			temp.x=vt.x+dis[i][0];
			temp.y=vt.y+dis[i][1];
			temp.t=vt.t+1;
			if(temp.x>=0&&temp.x<n&&temp.y>=0&&temp.y<m)
			{
				if(!vist[temp.x][temp.y])
		     	{
				if(mark[temp.x][temp.y]!='#'||temp.t%k==0)
				{
				  if(temp.x==e.x&&temp.y==e.y)
				  {
					ans=temp.t;
					return;
				  }
				  else
				 {
				 	if(temp.t%k==0)
					vist[temp.x][temp.y]=1;
					q.push(temp);
				 }
				
			    }
		
		      }
		    }
		}
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&k);
		     for(int i=0;i<n;i++)
		     {
		     	getchar();
		     	for(int j=0;j<m;j++)
		     	{
		     		scanf("%c",&mark[i][j]);
		     	    if(mark[i][j]=='Y')
		     	    {
		     	    	s.x=i;
		     	    	s.y=j;
		     	    	s.t=0;
		     	    }
		     	    else if(mark[i][j]=='G')
		     	    {
		     	    	e.x=i;
		     	    	e.y=j;
		     	    }
				 }
				
		     }
		     if(s.x==e.x&&s.y==e.y)
		     {
		     	printf("0\n");
		     	continue;
		     }
		     ans=INF;
    	     bfs();
    	     if(ans>=INF)
    		printf("Please give me another chance!\n");
    		else
    		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值