HDU 2955-Robberies(01背包变形)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19371    Accepted Submission(s): 7149


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 

Source
 

Recommend
gaojie

题目意思:

有个人去抢银行,给出这个人被捕的系数和银行数目,再给出每家银行的被捕危险系数和能抢的钱数,求最多能抢多少钱。

解题思路:

利用(1-被捕系数)安全系数。
double dp[MAXN];//表示抢钱为i时安全的最大几率
求出能抢的总数目,再用01背包求出dp数组,找到安全的情况下能抢得的最大数目。

AC代码:(不能用float阿阿阿!!会超时阿!double就木有关系呐!

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 10000//开小了会运行出错
#define max(x,y) ((x)>(y)?(x):(y))
double P;
int n,sum;
double dp[MAXN];//表示抢钱为i时安全的最大几率
struct Node
{
    int m;
    double p;
} a[MAXN];
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%lf%d",&P,&n);
        for(int i=0; i<n; ++i)
        {
            scanf("%d%lf",&a[i].m,&a[i].p);
            sum+=a[i].m;//总数目
        }
        memset(dp,0,sizeof(dp));//初始化
        dp[0]=1;//不抢最安全
        for(i=0; i<n; ++i) //01背包
            for(j=sum; j>=a[i].m; --j)
                dp[j]=max(dp[j],dp[j-a[i].m]*(1.0-a[i].p));//1-p表示安全的概率
        for(i=sum; i>=0; --i) //求若不被捕得最大所得
            if(dp[i]>1.0-P)
            {
                printf("%d\n",i);
                break;
            }
    }
    return 0;
}

递归超时:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 101
int m[MAXN],n;
double p[MAXN];
double dp[MAXN][MAXN];
int rec(int i,double j)
{
    int res;
    if(i==n)  res=0;
    else if(j<p[i]) res=rec(i+1,j);
    else res=max(rec(i+1,j),rec(i+1,j-p[i])+m[i]);
    return res;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        double P;
        cin>>P>>n;
        int i;
        for(i=0; i<n; ++i)
            cin>>m[i]>>p[i];
        cout<<rec(0,P)<<endl;
    }
    return 0;
}



改良版递归 还是超时:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 101
int m[MAXN],n;
float p[MAXN];
float dp[MAXN][MAXN];
int rec(int i,float j,int sum)
{
    int res;
    if(i==n)  res=sum;
    else if(j<p[i]) res=rec(i+1,j,sum);
    else res=max(rec(i+1,j,sum),rec(i+1,j-p[i],sum+m[i]));
    return res;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("D:/x/read.txt","r",stdin);
    freopen("D:/x/out.txt","w",stdout);
#endif
    int t;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        float P;
        scanf("%f%d",&P,&n);
        int i;
        for(i=0; i<n; ++i)
            scanf("%d%f",&m[i],&p[i]);
        printf("%d\n",rec(0,P,0));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值