POJ 3276-Face The Right Way(牛面向前方-开关问题)

Face The Right Way
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3965 Accepted: 1828

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer:  N 
Lines 2.. N+1: Line  i+1 contains a single character,  F or  B, indicating whether cow  i is facing forward or backward.

Output

Line 1: Two space-separated integers:  K and  M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For  K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source

题目意思:

N头牛排成一列1<=N<=5000。每头牛或者向前或者向后。为了让所有牛都 面向前方,农夫每次可以将K头连续的牛转向1<=K<=N,求操作的最少 次数M和对应的最小K。

解题思路:

每一个区间最多反转1次,多余的反转是无效的;

从最左边的牛开始考虑,如果它朝向背面则需要翻动区间[i, i + k - 1], 否则就不用翻动;

设f[i]为区间[i, i + k - 1]是否需要反转,需要为1,不需要为0;

考虑第i头牛是否需要翻动,只要知道这头牛最初的朝向及 ∑(j=i-k+1~j=i-1)f[j];

∑(j=(i+1)-k+1~j=(i+1)-1)f[j] = ∑(j=i-k+1~j=i-1)f[j] + f[i] - f[i-k+1];

再考察[n - k + 1, n - 1]的牛是否都以反转,来判断k值是否成立。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<malloc.h>
#define MAXN 5005
#define inf 0x3f3f3f3f
using namespace std;
//F0B1,1转0不转
int n,m;
int f[MAXN]; //保存区间[i,+k-1]是否进行反转的标志
int dir[MAXN]; //牛的方向

int calc(int k)//固定k,求最小的操作次数
{
    memset(f,0,sizeof(f));
    int i,res=0;//连续翻转的次数
    int sum=0;//f的和
    for(i=0; i+k<=n; ++i)//计算区间[i,+k-1]
    {
        if((dir[i]+sum)&1)  //if((dir[i]+sum)%2!=0)翻转奇数次改变状态,偶数次不改变
        {
            ++res;
            f[i]=1;
        }
        sum+=f[i];
        if(i-k+1>=0)
            sum-=f[i-k+1];
    }
    for(i=n-k+1; i<n; ++i) //检查剩下的牛是否有面向后方的
    {
        if((dir[i]+sum)&1) return -1;
        else if(i-k+1>=0) sum-=f[i-k+1];//把之前反转的次数删去
    }
    return res;
}

void solve()
{
    int K=1,M=n;
    for(int i=1; i<=n; ++i)
    {
        int m=calc(i);
        if(m>0&&m<M)
        {
            M=m;
            K=i;
        }
    }
    cout<<K<<" "<<M<<endl;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin>>n)
    {
        for(int i=0; i<n; ++i)
        {
            char c;
            cin>>c;
            if(c=='F') dir[i]=0;
            else dir[i]=1;
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值