Hdu 4618 Palindrome Sub-Array

Palindrome Sub-Array

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)



Problem Description
  A palindrome sequence is a sequence which is as same as its reversed order. For example, 1 2 3 2 1 is a palindrome sequence, but 1 2 3 2 2 is not. Given a 2-D array of N rows and M columns, your task is to find a maximum sub-array of P rows and P columns, of which each row and each column is a palindrome sequence.
 

Input
  The first line of input contains only one integer, T, the number of test cases. Following T blocks, each block describe one test case.
  There is two integers N, M (1<=N, M<=300) separated by one white space in the first line of each block, representing the size of the 2-D array.
  Then N lines follow, each line contains M integers separated by white spaces, representing the elements of the 2-D array. All the elements in the 2-D array will be larger than 0 and no more than 31415926.
 

Output
  For each test case, output P only, the size of the maximum sub-array that you need to find.
 

Sample Input
  
  
1 5 10 1 2 3 3 2 4 5 6 7 8 1 2 3 3 2 4 5 6 7 8 1 2 3 3 2 4 5 6 7 8 1 2 3 3 2 4 5 6 7 8 1 2 3 9 10 4 5 6 7 8
 

Sample Output
  
  
4
 

Source
2013 Multi-University Training Contest 2

直接暴力就好了,一些小细节导致训练的时候没A。。

#include<cstdio>

using namespace std;

#define Min(a,b) (a<b?a:b)
#define Max(a,b) (a>b?a:b)

int num[311][311];
int d1[311][311],d2[311][311];

int main()
{
    int T,N,M;
    int i,j,k;
    int cnt,tmp;

    scanf("%d",&T);

    while(T--)
    {
        scanf("%d%d",&N,&M);
        for(i=1;i<=N;i++)
            for(j=1;j<=M;j++)
            {
                scanf("%d",&num[i][j]);
            }
        for(i=1;i<=N;i++)
            for(j=1;j<=M;j++)
            {
                cnt=1;
                while(j-cnt>0 && j+cnt<=M && num[i][j-cnt]==num[i][j+cnt])
                    cnt++;
                d1[i][j]=cnt*2-1;
            }

        for(i=1;i<=N;i++)
            for(j=1;j<=M;j++)
            {
                cnt=1;
                while(i-cnt>0 && i+cnt<=N && num[i-cnt][j]==num[i+cnt][j])
                    cnt++;
                d2[i][j]=cnt*2-1;
            }

        int ans=1;
        for(i=1;i<=N;i++)
            for(j=1;j<=M;j++)
            {
                tmp=d1[i][j];
                for(k=1;k<=(tmp-1)/2;k++)
                {
                        if(!(i-k>0 || i+k<=N))
						{
							tmp=2*(k-1)+1;
							break;
						}
						if(d1[i-k][j]<tmp)
							tmp=Max(2*(k-1)+1,d1[i-k][j]);
                        if(d1[i+k][j]<tmp)
                            tmp=Max(2*(k-1)+1,d1[i+k][j]);
                }
                for(k=1;k<=(tmp-1)/2;k++)
                {
                        if(!(j-k>0 || j+k<=M))
						{
							tmp=2*(k-1)+1;
							break;
						}
						if(d2[i][j-k]<tmp)
							tmp=Max(2*(k-1)+1,d2[i][j-k]);
                        if(d2[i][j+k]<tmp)
                            tmp=Max(2*(k-1)+1,d2[i][j+k]);
                }
                if(tmp>ans)
                    ans=tmp;
            }

        for(i=1;i<=N;i++)
            for(j=1;j<=M;j++)
            {
                cnt=0;
                while(j-cnt>0 && j+1+cnt<=M && num[i][j-cnt]==num[i][j+1+cnt])
                    cnt++;
                d1[i][j]=cnt*2;
            }

        for(i=1;i<=N;i++)
            for(j=1;j<=M;j++)
            {
                cnt=0;
                while(i-cnt>0 && i+1+cnt<=N && num[i-cnt][j]==num[i+1+cnt][j])
                    cnt++;
                d2[i][j]=cnt*2;
            }
		 for(i=1;i<=N;i++)
            for(j=1;j<=M;j++)
            {
                tmp=d1[i][j];
				if(d1[i+1][j]<tmp)
					tmp=d1[i+1][j];
                for(k=1;k<=tmp/2-1;k++)
                {
                        if(!(i-k>0 || i+1+k<=N))
						{
							tmp=2*k;
							break;
						}
						if(d1[i-k][j]<tmp)
							tmp=Max(2*k,d1[i-k][j]);
                        if(d1[i+1+k][j]<tmp)
                            tmp=Max(2*k,d1[i+1+k][j]);
                }
				if(d2[i][j+1]<tmp)
					tmp=d1[i][j+1];
                for(k=1;k<=tmp/2-1;k++)
                {
                        if(!(j-k>0 || j+k<=M))
						{
							tmp=2*k;
							break;
						}
						if(d2[i][j-k]<tmp)
							tmp=Max(2*k,d2[i][j-k]);
                        if(d2[i][j+k]<tmp)
                            tmp=Max(2*k,d2[i][j+k]);
                }
                if(tmp>ans)
                    ans=tmp;
            }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值