Eclipse创建Maven工程时出现的Java Build path 问题

问题描述


  使用eclipse创建Maven工程时,出现如下错误:

Description Resource    Path    Location    Type
Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.   SpringBasic     Build path  JRE System Library Problem

解决方案


  原因是,maven build 的java build path路径未设置:
这里写图片描述

这里写图片描述


这里写图片描述


这里写图片描述


  效果图:

      

终极解决方案


  由于maven中update project 之后,可能还是会出现上述错误,可在pom.xml 文件中添加插件:

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

  参考 “Faceted Project Prblem (Java Version Mismatch)” error message

发布了72 篇原创文章 · 获赞 26 · 访问量 31万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览