hdu 6040 Hints of sd0061

Problem Description
sd0061, the legend of Beihang University ACM-ICPC Team, retired last year leaving a group of noobs. Noobs have no idea how to deal with m coming contests. sd0061 has left a set of hints for them.

There are n noobs in the team, the i-th of which has a rating ai. sd0061 prepares one hint for each contest. The hint for the j-th contest is a number bj, which means that the noob with the (bj+1)-th lowest rating is ordained by sd0061 for the j-th contest.

The coach asks constroy to make a list of contestants. constroy looks into these hints and finds out: bi+bj≤bk is satisfied if bi≠bj, bi < bk and bj < bk.

Now, you are in charge of making the list for constroy.

Input
There are multiple test cases (about 10).

For each test case:

The first line contains five integers n,m,A,B,C. (1≤n≤107,1≤m≤100)

The second line contains m integers, the i-th of which is the number bi of the i-th hint. (0≤bi < n)

The n noobs’ ratings are obtained by calling following function n times, the i-th result of which is ai.

unsigned x = A, y = B, z = C;
unsigned rng61() {
unsigned t;
x ^= x << 16;
x ^= x >> 5;
x ^= x << 1;
t = x;
x = y;
y = z;
z = t ^ x ^ y;
return z;
}

Output
For each test case, output “Case #x: y1 y2 ⋯ ym” in one line (without quotes), where x indicates the case number starting from 1 and yi (1≤i≤m) denotes the rating of noob for the i-th contest of corresponding case.

Sample Input
3 3 1 1 1
0 1 2
2 2 2 2 2
1 1

Sample Output
Case #1: 1 1 202755
Case #2: 405510 405510
题目大意:给你两个数组,a数组由题目给的函数得出,b数组由自己输入,每次输出a数组中第b[j]+1小的数。
解题思路:首先介绍一下STL中的nth_element()方法的使用 通过调用nth_element(start, start+n, end) 方法可以使第n大元素处于第n位置(从0开始,其位置是下标为 n的元素),并且比这个元素小的元素都排在这个元素之前,比这个元素大的元素都排在这个元素之后,但不能保证他们是有序的。借助这个函数,这个题就很好解决。用了这个函数后,我们可以从最大的开始找起。

#include <bits/stdc++.h>

using namespace std;

unsigned A,B,C,x,y,z;
int b[110],idb[110];
unsigned a[10000007],ans[110];
unsigned rng61() {
  unsigned t;
  x ^= x << 16;
  x ^= x >> 5;
  x ^= x << 1;
  t = x;
  x = y;
  y = z;
  z = t ^ x ^ y;
  return z;
}
bool cmp(const int x1,const int y1){
    return b[x1]>b[y1];
}
int main()
{
    int c = 0;
    long long n,m;
    while(~scanf("%lld %lld %u %u %u",&n,&m,&x,&y,&z)){
        for(int i = 0; i < n; i++)
            a[i] = rng61();
        for(int i = 0; i < m; i++){
            scanf("%d",&b[i]);
            idb[i] = i;
        }
      sort(idb,idb+m,cmp);
      int p,Last = n;
      for(int i=0;i<m;i++){
          p = idb[i];
          //cout<<idb[i]<<' '<<b[p]<<endl;
          nth_element(a,a+b[p],a+Last);
          ans[p] = a[b[p]];
          Last = b[p];
      }
       printf("Case #%d:",++c);
       for(int i=0;i<m;i++)
        printf(" %u",ans[i]);
       printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值