HDU1142 A Walk Through the Forest(SPFA+记忆化搜索)

24 篇文章 0 订阅
19 篇文章 0 订阅

A Walk Through the Forest

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 32   Accepted Submission(s) : 12
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 

Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 

Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

Sample Input

5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0

Sample Output

2
4

Source

University of Waterloo Local Contest 2005.09.24


题意:

求出2到各个点的最短路,求从1到2的路径有多少,路径要求如下:

1---->a---->b----->2
这里要求a到2的最短路径大于b到2的最短路径,此时这条路才是可以选的。



point:

  1. 因为边的数量并没有说明,所以用邻接矩形比较好。
  2. 暴力DFS搜索路径数量会TLE,用记忆化搜索。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
using namespace std;
const int N = 1000+20;
const int inf=0x3f3f3f3f;
int mp[N][N];
int n,m;
int dis[N];
int vis[N];
void spfa()
{
    memset(dis,inf,sizeof dis);
    memset(vis,0,sizeof vis);
    dis[2]=0;
    vis[2]=1;
    queue<int >q;
    while(!q.empty()) q.pop();
    q.push(2);
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        vis[now]=0;
        for(int i=1;i<=n;i++)
        {
            if(dis[i]>dis[now]+mp[now][i])
            {
                dis[i]=dis[now]+mp[now][i];
                if(vis[i]==0) vis[i]=1,q.push(i);
            }
        }
    }
}
int dp[N];
int dfs(int x)
{
    if(dp[x]) return dp[x];
    if(x==2) return 1;
    for(int i=1;i<=n;i++)
    {
        if(dis[x]>dis[i]&&mp[x][i]!=inf)
        {
            dp[x]+=dfs(i);
        }
    }
    return dp[x];
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        memset(mp,inf,sizeof mp);
        scanf("%d",&m);
        for(int i=1; i<=m; i++)
        {
            int a,b,d;
            scanf("%d %d %d",&a,&b,&d);
            mp[a][b]=mp[b][a]=d;

        }
        spfa();
        memset(dp,0,sizeof dp);
        printf("%d\n",dfs(1));

    }

}

记忆化搜索还是没什么印象,唉!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值