HDU 2852 KiKi's K-Number (树状数组+二分)

KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4144    Accepted Submission(s): 1866


Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?
 

Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.
 

Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!". 
 

Sample Input
  
  
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
 

Sample Output
  
  
No Elment! 6 Not Find! 2 2 4 Not Find!
 

Source
 

从a+1到100000二分。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define  LL long long
const int N = 100000;
int sum[N+3];
int num[N+3];
int lowbit(int x)
{
    return x&-x;
}
void add(int x,int y)
{
    for(int i=x;i<=N;i+=lowbit(i))
    {
        sum[i]+=y;
    }
}
int query(int x)
{
    int ans=0;
    for(int i=x;i>=1;i-=lowbit(i))
    {
        ans+=sum[i];
    }
    return ans;
}
void work(int a,int k)
{
    if(query(N)-query(a)<k)
    {
        printf("Not Find!\n");
        return;
    }
    int l=a+1,r=N;
    int mid=(l+r)>>1;
    while(l!=r)//注意二分的使用。
    {
        int now=query(mid)-query(a);
        if(now>=k)
        {
            r=mid;
        }
//      else if(now==k)
//        {
//            while(num[mid]==0)
//            {
//                mid--;
//            }
//            printf("%d\n",mid);
//            return ;
//        }
        else
        {
//            while(num[mid]==0)
//            {
//                mid++;
//            }
            l=mid+1;
        }
        mid=(l+r)>>1;
    }
    printf("%d\n",r);
    
}
int main()
{
    int n,p,e,a,k;
    while(~scanf("%d",&n))
    {
        memset(sum,0,sizeof sum);
        memset(num,0,sizeof num);
        while(n--)
        {
            scanf("%d",&p);
            if(p==0)
            {
                scanf("%d",&e);
                num[e]++;
                add(e,1);
            }
            else if(p==1)
            {
                scanf("%d",&e);
                if(num[e]==0) printf("No Elment!\n");
                else num[e]--,add(e,-1);
            }
            else if(p==2)
            {
                scanf("%d%d",&a,&k);
                work(a,k);
            }
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值