POJ 1905 Expanding Rods(二分搜索)

10 篇文章 0 订阅

Expanding Rods

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17687 Accepted: 4716

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed. 

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

Source

Waterloo local 2004.06.12

 

题意:

给你弧长和弦长,求高度。

POINT:

利用高度越高,弧越长的原理来二分。

好久没写二分答案的都忘记了。

 

#include <iostream>
#include <string.h>
#include <vector>
#include <algorithm>
#include <math.h>
#include <stdio.h>
using namespace std;

int main()
{
    double l,n,c;
    while(~scanf("%lf %lf %lf",&l,&n,&c))
    {
        if(l<0&&n<0&&c<0) break;
        double l1=(1 + n * c)* l;
        if(l1==l) printf("0.000\n");
        else
        {
            double ll=0,r=l/2.0;
            double mid;
            while(r-ll>0.000001)
            {
                mid=(ll+r)/2;
                double R=(l*l/4+mid*mid)/(2*mid);
                double x=asin(l/2/R)*2*R;
                if(x>l1)
                    r=mid;
                else ll=mid;
            }
            printf("%.3f\n",mid);
        }
    }
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值