POJ - 2010 Moo University - Financial Aid(优先队列)

Financial Aid
Time limit 1000 ms
Memory limit 30000 kB

Description
Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,”Moo U” for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university’s limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.

Input

  • Line 1: Three space-separated integers N, C, and F

  • Lines 2..C+1: Two space-separated integers per line. The first is the calf’s CSAT score; the second integer is the required amount of financial aid the calf needs

Output
* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.

Sample Input
3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output
35

题目大意:有N只牛,你只能从中选C只,且你只有F单位的资金能资助他,你的目的是使得资助的牛的分数的中位数最大。

最近不知怎么的,拿到类似的题目就想暴力解,但也就是想想 ヽ(・ω・。)ノ
这题的意思也有点枚举的意思。首先先按照分数对牛进行排序,(这里借助了优先队列)然后从后往前一个个枚举过来,看第i只牛左边n/2的最小值和右边n/2的最小值的和再加上第i只得资助金额,如果小于F,那么就是最大的啦╰(°▽°)╯

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
    int s,f;
    bool operator <(const node &x) const
    {
        return f<x.f;
    }
}cow[100010];

int cmp(node a,node b)
{
    return a.s<b.s;
}

int n,c,f;
int l[100005];
int r[100005];
int suml,sumr;
int main()
{
    scanf("%d%d%d",&n,&c,&f);
    for(int i=0;i<c;i++)
        scanf("%d%d",&cow[i].s,&cow[i].f);
    sort(cow,cow+c,cmp);
    priority_queue<node>ql,qr;
    suml=0;
    sumr=0;
    for(int i=0;i<c;i++)
    {
        if(i<n/2)
        {
            suml+=cow[i].f;
            ql.push(cow[i]);
        }
        else
        {
            l[i]=suml;
            if(cow[i].f<ql.top().f)
            {
                suml-=ql.top().f;
                suml+=cow[i].f;
                ql.pop();
                ql.push(cow[i]);
            }
        }
    }
    for(int i=c-1;i>=0;i--)
    {
        if(i>c-1-n/2)
        {
            qr.push(cow[i]);
            sumr+=cow[i].f;
        }
        else
        {
            r[i]=sumr;
            if(cow[i].f<qr.top().f)
            {
                sumr-=qr.top().f;
                sumr+=cow[i].f;
                qr.pop();
                qr.push(cow[i]);
            }
        }
    }
    int sum=-1;
    for(int i=c-1-n/2;i>=n/2;i--)
    {
        if(l[i]+r[i]+cow[i].f<=f)
        {
            sum=cow[i].s;
            break;
        }
    }
    printf("%d\n",sum);
}

ps.一定要看清题目啊啊啊啊!如果不存在符合的情况,要输出-1的啊啊啊啊啊啊,我一开始初始化为0,wa了三遍啊 (´Д`)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值