Uva 507 最大子矩阵和

A - Maximum Sum
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

Background

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

The Problem

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size tex2html_wrap_inline33 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

displaymath35

is in the lower-left-hand corner:

displaymath37

and has the sum of 15.

Input and Output

The input consists of an tex2html_wrap_inline39 array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by tex2html_wrap_inline43 integers separated by white-space (newlines and spaces). These tex2html_wrap_inline43 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [-127, 127].

The output is the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7  0 9  2 -6  2
-4  1 -4  1 -1
8  0 -2

Sample Output

15

 题意:
最大子矩阵和的问题,期间注意sum的初始化和b的变化,当b>0的时候
b+=a[j];b<=0时 b=a[j];
方法:把i行到j行的上下行的数据相加。应用一维的最大字段和方法。
代码:
     
     
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <string>
#include <set>
#include <map>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#define MAXX 100+10
#define inf 0x3f3f3f3f
using namespace std;
 
int maxsum(int *a, int n)
{
int b=0, sum=-2147483645;
for (int i=0; i<n; i++)
{
if (b<0)
b = a[i];
else
b += a[i];
if (b>sum)
sum = b;
}
return sum;
}
 
int main()
{
#ifdef LOCAL
freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
#endif // LOCAL
int n;
while (scanf("%d", &n)!=EOF)
{
int a[MAXX][MAXX], b[MAXX];
for (int i=0; i<n; i++)
for (int j=0; j<n; j++)
scanf("%d", &a[i][j]);
int ans = -2147483645;
for (int i=0; i<n; i++)
{
memset(b, 0, sizeof(b));
for (int j=i; j<n; j++)
{
for (int k=0; k<n; k++)
b[k] += a[j][k];
int maxx = maxsum(b, n);
if (maxx > ans)
ans = maxx;
}
}
printf("%d\n", ans);
}
return 0;
}
相关的知识:  http://blog.csdn.net/liufeng_king/article/details/8632430

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值