uva489-Hangman Judge

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:
  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.

这题主要是翻译的问题,晕啊,英文是硬伤啊,大概意思是你要给出一些字母,这些字母要再给出的答案中存在,并且只要猜过的就不再猜啦,不论对与错,所以这里用到一点hash,具体看代码吧:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main(){
     int r,w,i,j,len,len1,num,sign,k;
     char s[100],l[250],s1[100];
     while(scanf("%d",&r)&&r!=-1){
         num=0;
         getchar();
         gets(s);
         len=strlen(s);
         memset(l,0,sizeof(l));
         gets(s1);
         len1=strlen(s1);
         for(i=0;i<len1;i++){
             if(l[s1[i]]==0){
                 for(j=0;j<len;j++){
                     if(s1[i]==s[j]){
                         break;
                     }
                     if(j==len-1&&s1[i]!=s[j])
                         num++;
                 }
                 l[s1[i]]=1;
             }
             if(num==7){
                printf("Round %d\n",r);
                printf("You lose.\n");
                sign=1;
                break;
             }
             sign=1;
             for(k=0;k<len;k++){
                 if(l[s[k]]==0){
                     sign=0;  
                     break;
                 }
             }
             if(sign){
                printf("Round %d\n",r);
                printf("You win.\n");
                break;
             }
         }
         if(!sign){
            printf("Round %d\n",r);
            printf("You chickened out.\n");
         }
     }
     return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值