求n^k得前三位和后三位(Leading and Trailing)

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nkcontains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

后三位求法:直接快速幂模1000即可;

前三位求法:记      d = a + b = {log_{10}}^{n}; a为d的整数部分,b为小数部分.

则 n = 10^{a}*10^{b};  即10^{b} = n/10^{a};    则10^{b+2}为前三位

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
ll mul(ll a, ll b, int mod)
{
    ll res = 1;
    while(b)
    {
        if(b&1)
            res = (res*a)%mod;
        a = (a*a)%mod;
        b >>= 1;
    }
    return res;
}

int main()
{
    int T,cnt = 1;
    scanf("%d",&T);
    while(T--)
    {
        ll n,k;
        scanf("%lld %lld",&n,&k);
        int temp2 = (int)mul(n,k,1000);
        double t = k*log10(n);
        int temp1 = pow(10,t-(int)t)*100;
        printf("Case %d: %d %03d\n",cnt++,temp1,temp2);
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值