CF1279D-Santa's Bot-逆元运算

Description

Santa Claus has received letters from n different kids throughout this year. Of course, each kid wants to get some presents from Santa: in particular, the i-th kid asked Santa to give them one of ki different items as a present. Some items could have been asked by multiple kids.

Santa is really busy, so he wants the New Year Bot to choose the presents for all children. Unfortunately, the Bot’s algorithm of choosing presents is bugged. To choose a present for some kid, the Bot does the following:

  • choose one kid x equiprobably among all n kids;
  • choose some item y equiprobably among all kx items kid x wants;
  • choose a kid z who will receive the present equipropably among all n kids (this choice is independent of choosing x and y); the resulting triple (x,y,z) is called the decision of the Bot.

If kid z listed item y as an item they want to receive, then the decision valid. Otherwise, the Bot’s choice is invalid.

Santa is aware of the bug, but he can’t estimate if this bug is really severe. To do so, he wants to know the probability that one decision generated according to the aforementioned algorithm is valid. Can you help him?

Input

The first line contains one integer n (1≤n≤106) — the number of kids who wrote their letters to Santa.

Then n lines follow, the i-th of them contains a list of items wanted by the i-th kid in the following format: ki ai,1 ai,2 … ai,ki (1≤ki,ai,j≤106), where ki is the number of items wanted by the i-th kid, and ai,j are the items themselves. No item is contained in the same list more than once.

It is guaranteed that ∑ i = 1 n k i ≤ 1 0 6 \sum_{i=1}^n k_i \leq10^6 i=1nki106.

Output

Print the probatility that the Bot produces a valid decision as follows:

Let this probability be represented as an irreducible fraction x y \frac{x}{y} yx. You have to print x⋅y−1 mod 998244353, where y−1 is the inverse element of y modulo 998244353 (such integer that y⋅y−1 has remainder 1 modulo 998244353).

Sample Input

5
2 1 2
2 3 1
3 2 4 3
2 1 4
3 4 3 2

Sample Output

798595483

核心思想:

操作的前两步是选出一种礼物,第三步将礼物送给一个人。
先求出每种礼物被选中的概率,再乘上想要此礼物的孩子们的占比。求和就是答案。

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=1e6+20;
const ll mo=998244353;
ll cnt[N],p[N];//cnt[i]表示想要第i种礼物的人数,p[i]表示前两步选中第i种礼物的概率 
ll fun(ll x,ll y)//gcd 
{
	if(x%y==0)
		return y;
	return fun(y,x%y);
}
ll f(ll t,ll b)//快速幂求逆元 
{
	ll ans=1;
	t%=mo;
	while(b)
	{
		if(b&1)ans=(ans*t)%mo;
		t=(t*t)%mo;
		b>>=1;
	}
	return ans;
}
int main()
{
	int n,k,z;
	cin>>n;
	for(int i=1; i<=n; i++)//处理前两步 
	{
		scanf("%d",&k);
		for(int j=1; j<=k; j++)
		{
			scanf("%d",&z);
			cnt[z]++;
			p[z]=(p[z]+f(ll(n)*k,mo-2))%mo;
		}
	}
	ll ans=0,te=f(n,mo-2);
	for(int i=1; i<N; i++)//第三步 
		ans=(ans+p[i]*cnt[i]%mo*te%mo)%mo;
	cout<<ans<<endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值