Coloring Game-快速幂

题目描述:

David has a white board with 2×N grids.He decides to paint some grids black with his brush.He always starts at the top left corner and ends at the bottom right corner, where grids should be black ultimately.

Each time he can move his brush up(↑), down(↓), left(←), right(→), left up(↖), left down(↙), right up(↗), right down (↘) to the next grid.

For a grid visited before,the color is still black. Otherwise it changes from white to black.

David wants you to compute the number of different color schemes for a given board. Two color schemes are considered different if and only if the color of at least one corresponding position is different.

输入描述:

One line including an integer n(0<n≤109)

输出描述:

One line including an integer, which represent the answer  mod 1000000007

输入样例:

2

输出样例:

4

题目大意:

给出2XN个纯白方格,戴维从左上角出发,到右下角终止,戴维可以走 brush up(↑), down(↓), left(←), right(→), left up(↖), left down(↙), right up(↗), right down (↘) ,共八个方向,每到一个格子,这个格子会立刻被染成黑色,一个格子可以走多次,问走完后不同的着色图案有多少种。

核心思想:

对于第一列,有两种情况,上黑下白或者上黑下黑;
对于最后一列,有两种情况,上白下黑或者上黑下黑;
对于其他列,每列有三种情况,上白下黑、上黑下白或者上黑下黑。
总情况:
当n==1时,是 1 (只能是上黑下黑)
当n>=2时,是 2X3n-2X2,即 4X3n-2
n很大,快速幂即可。

代码如下:

#include<iostream>
#include<cstdio>
#define mo 1000000007
using namespace std;
typedef long long ll;
int main()
{
	ll n;
	cin>>n;
	if(n==1)
	{
		printf("1\n");
		return 0;
	}
	ll b=n-2,ans=4,t=3;
	while(b)
	{
		if(b&1)ans=(ans*t)%mo;
		b>>=1;
		t=(t*t)%mo;
	}
	printf("%lld\n",ans);
	return 0;
}

运行结果:

在这里插入图片描述

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值