CF 245H-Queries for Number of Palindromes-两次区间dp

You’ve got a string s = s1s2… s|s| of length |s|, consisting of lowercase English letters. There also are q queries, each query is described by two integers li, ri (1 ≤ li ≤ ri ≤ |s|). The answer to the query is the number of substrings of string s[li… ri], which are palindromes.

String s[l… r] = slsl+1… sr (1 ≤ l ≤ r ≤ |s|) is a substring of string s = s1s2… s|s|.

String t is called a palindrome, if it reads the same from left to right and from right to left. Formally, if t = t1t2… t|t| = t|t|t|t|-1… t1.

Input

The first line contains string s (1 ≤ |s| ≤ 5000). The second line contains a single integer q (1 ≤ q ≤ 106) — the number of queries. Next q lines contain the queries. The i-th of these lines contains two space-separated integers li, ri (1 ≤ li≤ ri ≤ |s|) — the description of the i-th query.

It is guaranteed that the given string consists only of lowercase English letters.

Output

Print q integers — the answers to the queries. Print the answers in the order, in which the queries are given in the input. Separate the printed numbers by whitespaces.

Sample Input

caaaba
5
1 1
1 4
2 3
4 6
4 5

Sample Output

1
7
3
4
2

题目大意:

给定一个只由小写字母构成的字符串。
接下来是q次询问,每次询问给出l,r。
对于每次询问,输出从第l个字符到第r个字符有多个回文子串。
注意:子串和子序列是不一样的!

核心思想:

两次区间dp,d1[l][r]和d2[l][r]。
s[l,r]是回文串,则d1[l][r]=1,否则,d1[l][r]=0;
d2[l][r]表示s[l,r]中有多少个回文子串
d1状态转移方程
d1[l][r]=(d1[l+1][r-1]&&s[l]==s[r])
d2状态转移方程
d2[l][r]=d2[l][r-1]+d2[l+1][r]-d2[l+1][r-1]+d1[l][r];
注意:在计算d1时,会用到d1[l+1][l]的值,所以d1[l+1][l]也需要初始化

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm> 
using namespace std;
typedef long long ll;
const int N=5e3+10;
char s[N]; 
bool d1[N][N];//若子串i~j为回文串,则d1[i][j]=1,否则=0
ll d2[N][N];//d2[i][j]为i~j中回文串个数
int main()
{
	while(scanf("%s",s)!=EOF)
	{
		int len=strlen(s);
		//初始化 
		for(int i=0;i<len;i++)
		{
			d1[i][i]=d1[i+1][i]=1;
			d2[i][i]=1;
		}
		//d1 
		for(int d=2;d<=len;d++)
			for(int l=0;l+d-1<len;l++)
			{
				int r=l+d-1;
				d1[l][r]=(d1[l+1][r-1]&&s[l]==s[r]);
			}
		//d2 
		for(int d=2;d<=len;d++)
			for(int l=0;l+d-1<len;l++)
			{
				int r=l+d-1;
				d2[l][r]=d2[l][r-1]+d2[l+1][r]-d2[l+1][r-1]+d1[l][r];
			}
		//输出 
		int q,x,y;
		scanf("%d",&q);
		while(q--)
		{
			scanf("%d%d",&x,&y);
			printf("%lld\n",d2[x-1][y-1]);
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值