POJ 3268 Silver Cow Party 最短路

题目:

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

最短路径问题,求两次最短路径。我用了正向建图和反向建图,用两张图记录各个点间距离,由此分别计算各个点到X的距离和X到各个点的距离。


代码:

//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
using namespace std;

int Map1[1005][1005],Map2[1005][1004];
int visit[1005];
int n,m,x,a,b,dis;
void shortest1(int pos)
{
    queue <int> q;
    int temp;
    for (int i=1;i<=n;i++)
    {
        if (i!=pos && Map1[pos][i]!=inf)
        {
            q.push(i);
        }
    }
    while (q.size())
    {
        memset(visit,0,sizeof(visit));
        temp=q.front();
        q.pop();
        for (int i=1;i<=n;i++)
        {
            if (Map1[temp][i]+Map1[pos][temp]<Map1[pos][i])
            {
                //cout<<i<<' ';
                Map1[pos][i]=Map1[temp][i]+Map1[pos][temp];
                if (!visit[i])
                {
                    visit[i]=1;
                    q.push(i);
                }
            }
        }
    }
    return;
}
void shortest2(int pos)
{
    queue <int> q;
    int temp;
    for (int i=1;i<=n;i++)
    {
        if (i!=pos && Map2[pos][i]!=inf)
        {
            q.push(i);
        }
    }
    while (q.size())
    {
        memset(visit,0,sizeof(visit));
        temp=q.front();
        q.pop();
        for (int i=1;i<=n;i++)
        {
            if (Map2[temp][i]+Map2[pos][temp]<Map2[pos][i])
            {
                //cout<<i<<' ';
                Map2[pos][i]=Map2[temp][i]+Map2[pos][temp];
                if (!visit[i])
                {
                    visit[i]=1;
                    q.push(i);
                }
            }
        }
    }
    return;
}
int main()
{
    scanf("%d%d%d",&n,&m,&x);
    memset(Map1,inf,sizeof(Map1));
    memset(Map2,inf,sizeof(Map2));
    for (int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&a,&b,&dis);
        Map1[a][b]=dis;
        Map2[b][a]=dis;              //反向建图
    }
    for (int i=1;i<=n;i++)
    {
        Map1[i][i]=0;
        Map2[i][i]=0;
    }

    shortest1(x);                  //从各个点到x点的最短距离
    shortest2(x);                  //从x到各个点的最短距离
    int ans=0;
    for (int i=1;i<=n;i++)
    {
        if (Map1[x][i]+Map2[x][i]>ans)
            ans=Map1[x][i]+Map2[x][i];
    }
    printf("%d\n",ans);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值