HDOJ-5363 Key Set

Key Set
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1688 Accepted Submission(s): 892

Problem Description
soda has a set S with n integers {1,2,…,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤109), the number of integers in the set.

Output
For each test case, output the number of key sets modulo 1000000007.

Sample Input
4
1
2
3
4

Sample Output
0
1
3
7

由题意可得出,输出应为2^(n-1)-1。但是数比较大,应该用快速幂。

代码如下:

#include <cstdio>
#include <algorithm>
#include<stdint.h>
#include<math.h>
#include<string.h>
__int64 quickpow(__int64 n,__int64 m,__int64 mod)
{
    __int64 a=1,b=n;
    while(m)
    {
        if(m&1)
        {
            a=(b*a)%mod;
        }
        b=(b*b)%mod;
        m>>=1;
    }
    return a;
}
using namespace std;
int main()
{
    __int64 t,n,mod=1000000007;
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        printf("%I64d\n",quickpow(2,n-1,mod)-1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值