SDUT3343数据结构实验之二叉树四:还原二叉树

数据结构实验之二叉树四:还原二叉树

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入

输入数据有多组,每组数据第一行输入 1 个正整数 N(1 <= N <= 50) 为树中结点总数,随后 2 行先后给出先序和中序遍历序列,均是长度为 N 的不包含重复英文字母 ( 区分大小写 ) 的字符串。

输出

 输出一个整数,即该二叉树的高度。

示例输入

9 
ABDFGHIEC
FDHGIBEAC

示例输出

5
#include <stdio.h>
 #include <stdlib.h>
 struct node
 {
     char ch;
     struct node *lc,*rc;
 };
 char s1[128],s2[128];
 struct node *creat(char *s1,char *s2,int len)
 {
     struct node *root;
     char *x;
     int m;
     if(len<=0) return NULL;

     root=(struct node *)malloc(sizeof(struct node));
     root->ch=*s1;//先序第一个为根
     for(x=s2;x!=NULL;x++)//查找中序的根位置
         if(*x==*s1)
            break;
     m=x-s2;//左子树长度
     root->lc=creat(s1+1,s2,m);
     root->rc=creat(s1+m+1,x+1,len-m-1);//找右子树
 return root;
 }
 int deep(struct node *root)
 {
     int l,r;
     if(!root)
        return 0;
     else
     {
         l=deep(root->lc);
         r=deep(root->rc);
         if(l>=r)
            return l+1;
         else
            return r+1;
     }
     return 1;
 }
 int main()
 {
     int n,len;
     struct node *root;
     while(~scanf("%d",&n))
     {
         scanf("%s%s",s1,s2);
     root=(struct node *)malloc(sizeof(struct node));
     root=creat(s1,s2,n);//建树
     printf("%d\n",deep(root));
     }
     
     return 0;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值