PAT甲级1014 Waiting in Line (30)(30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer~1~ is served at window~1~ while customer~2~ is served at window~2~. Customer~3~ will wait in front of window~1~ and customer~4~ will wait in front of window~2~. Customer~5~ will wait behind the yellow line.

At 08:01, customer~1~ is done and customer~5~ enters the line in front of window~1~ since that line seems shorter now. Customer~2~ will leave at 08:02, customer~4~ at 08:06, customer~3~ at 08:07, and finally customer~5~ at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry

简单的模拟题,注意一点:当服务开始时间>=17:00时输出"Sorry",而不是服务结束时间。

每个窗口相当于一个队列,顾客就相当于元素。满队时,只有队列第一个元素出队,才能插入新元素。 

故而我们可以比较这N个窗口第一个人结束时间,哪个时间小,就进入哪个窗口。

另外,为了简便,可以先用分钟处理数据,输出时再换算。

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int N, M, K, Q;
    cin>>N>>M>>K>>Q;

    queue<int> windows[24];//窗口
    int winend[24];//窗口办理完所有业务的结束时间
    int protime[1024];//顾客的办理时间
    int finish[1024];//顾客办理结束时间
    memset(winend, 0, sizeof(winend));
    memset(finish, 0 ,sizeof(finish));
    for(int i=1; i<=N*M&&i<=K; i++){//先将窗口循环排满
        cin>>protime[i];
        int pos = (i % N == 0 ? N : i % N);
        windows[pos].push(i);
        finish[i] = winend[pos] + protime[i];
        winend[pos] = finish[i];
    }


    for(int i = N*M+1; i<=K; i++){
        cin>>protime[i];

        int pos = 1;
        int Min = finish[windows[1].front()];
        for(int j=2; j<=N; j++){//查找最先能够进入的窗口
            int cnt = windows[j].front();
            if(Min > finish[cnt]){
                pos = j;
                Min = finish[cnt];
            }
        }

        windows[pos].pop();//第一个人出队
        windows[pos].push(i);//顾客i入队
        finish[i] = winend[pos] + protime[i];//顾客i办理完成的时间
        winend[pos] = finish[i];//更新窗口pos的结束时间
    }

    while(Q--){
        int q;
        cin>>q;
        if(finish[q] - protime[q]>=540){//开始时间超过17:00
            cout<<"Sorry\n";
        } else{
            int h = finish[q] / 60 + 8;
            int m = finish[q] % 60;
            printf("%02d:%02d\n", h, m);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值