POJ3050 Hopscotch 穷举搜索 DFS Map容器再尝试

Description
The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.
They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).
With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).
Determine the count of the number of distinct integers that can be created in this manner.
Input
Lines 1…5: The grid, five integers per line
Output
Line 1: The number of distinct integers that can be constructed
Sample Input
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1
Sample Output
15
Hint
OUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

题目大意:
给定一个5*5的地图,每个格子上有一个个位数。从一个格子出发(上下左右4个方向),走5步将数字连起来可以构造出一个6位数。问该地图可以构造出多少个不同的6位数。
解题思路:
本题目的数据量较小,搜索深度也较小,可以对每一个格子都进行DFS,使用Map容器保存已经搜索到的6位数,最终的结果就是Map容器中的元素的个数。

AC代码

#include<iostream>
#include<map>
#include<string>
using namespace std;
int ans;
map<string, int> que;
char a[6][6];
int mynext[4][2] = { 1,0,-1,0,0,1,0,-1 };
void DFS(int x, int y, int n, string s) {
	s += a[x][y];
	if (n == 0) {
		if (que.find(s) == que.end()) { 
			que[s] = ++ans;
		}
		return;
	}
	for (int i = 0; i < 4; i++) {
		int nx = x + mynext[i][0];
		int ny = y + mynext[i][1];
		if (nx < 1 || nx>5 || ny < 1 || ny>5) continue;
		DFS(nx, ny, n - 1, s);
	}
	return;
}
int main() {
	for (int i = 1; i < 6; i++) {
		for (int j = 1; j < 6; j++) {
			cin >> a[i][j];
		}
	}
	ans = 0;
	for (int i = 1; i < 6; i++) {
		for (int j = 1; j < 6; j++) {
			DFS(i, j, 5, "");
		}
	}
	cout << ans << endl;
	//system("pause");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值