Android studio 解决各种错误

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/RenRuiTao/article/details/78517647

1.

安装Android Studio,打开时却提示 unable to access android sdk add-on list

解决方法:在安装Android studio路径下找到idea.properties文件,用记事本或其他记事本打开,添加disable.android.first.run=true,保存即可。


2.

打开Android studio 弹出显示Sdk报错找不见

解决方法:打开Android Studio创建项目页面,找到Configgure->SDK Manager ->选择SDK 路径 点击Edit->选择上Android SDK Platform 在下方写上下载存放的路径(住路径不能有空格),点击下一步开始下载(这时最短需要等待20分钟左右),下载完成点击finsh再点击OK即可!!
image.png


3.

代码The SDK platform-tools version (26.0.2) is too old to check APIs compiled with API 27…. 错误 ,意思是SDK平台工具版本(26.0.2)太旧,无法检查使用API​​ 27编译的API. 虽然不影响代码的运行但是看着不舒服。

解决方法:如下图 :

打开SDK Manager 找到SDK Platform-tools 更新(图中已经更新)。

更新后 打开 设置 找到Invalidate Caches/…. 重启更新即可。

如更新后还没有解决,找到SDK Platforms 下载API 26,下载完毕,打开 设置 找到Invalidate Caches/…. 重启更新即可。


4.

导入别人项目时报 Can’t start Git: git.exe 错误

解决方法:下载Git客户端–>配置Git路径
image.png
配置完后我们点下路径后的Test按钮,若出现该Success提示框则表明配置成功:
image.png


    5.

studio 导入项目时错误.

gradle project sync failed.Basic functionality(e.g.editing,debugging) will not work properly.

image.png

解决方法:

然后进入项目目录下,找到 gradle\wrapper\gradle-wrapper.properties 文件,记事本打开,内容如下:

    #Mon Oct 30 19:59:02 CST 2017
    distributionBase=GRADLE_USER_HOME
    distributionPath=wrapper/dists
    zipStoreBase=GRADLE_USER_HOME
    zipStorePath=wrapper/dists
    distributionUrl=https://services.gradle.org/distributions/gradle-4.1-all.zip
    android.injected.build.model.only.versioned = 3
有一句:https://services.gradle.org/distributions/gradle-4.1-all.zip

studio会下载上面的Gradle,不知道什么原因下载不下来,我们可以手动下载这个版本的Gradle,无需解压 直接拷贝到:

  C:\Users\Administrator\ .gradle\wrapper\dists\      下即可,重启studio,问题解决

如遇其他错误可评论留言,看见后回复。

阅读更多
换一批

没有更多推荐了,返回首页