PAT A1071 Speech Patterns (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805398257647616

题目描述
People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

输入
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入
Can1: “Can a can can a can? It can!”

样例输出
can 5

代码

#include <iostream>
#include <string>
#include <map>
using namespace std;

bool check(char c) {
	if(c >='A' && c <= 'Z' || c >='a' && c <= 'z' || c >='0' && c <= '9')
		return true;
	else
		return false;
}

int main() {
	int num = 1, max = 0;
	string str, temp, maxstr;
	map<string, int> mp;
	getline(cin, str);
	for(int i = 0; i <= str.size(); i++) {								// 要到str.size(),不然最后一个单词没法结束
		if(str[i] >= 'A' && str[i] <= 'Z')
			str[i]  = str[i] - 'A' + 'a';
		if(check(str[i]))												//符合字母字符
			temp += str[i];
		else if(!check(str[i]) && check(str[i - 1]) && i > 0) {			//不符合,但前一个符合(单词的结尾后的那个字符)
			mp[temp]++;
			if(mp[temp] > max || (mp[temp] == max && temp < maxstr)) {	//记录出现次数最多的单词
				max = mp[temp];
				maxstr = temp;
			}
			temp.clear();
		}
	}
	cout << maxstr << ' ' << mp[maxstr] << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值