POJ - 2823 Sliding Window(单调队列)

An array of size  n ≤ 10  6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input
The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 
Sample Input
8 3
1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7

#pragma warning (disable : 4996)
#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <cstdlib>
#include <vector>
#include <map>
#include <queue>
#include <cmath>
#include <stack>
#include <algorithm>
#include <cmath>
using namespace std;
int all[1000002];
int mins[1000002];
int maxs[1000002];
int main()
{
	int n, m;
	scanf("%d%d", &n, &m);
	for (int a = 0; a < n; a++)
		scanf("%d", &all[a]);
	deque<int>line;//控制长度
	int len = 0;
	for (int a = 0; a < n; a++)
	{
		if (line.empty())
			line.push_back(a);
		else
		{
			if (all[a] > all[line.back()])
				line.push_back(a);//构造递增队列, 使得最前的是最小的
			else
			{
				while (!line.empty() && all[a] <= all[line.back()])//数组不要越界
				{
					line.pop_back();
				}
				line.push_back(a);
			}
		}
		if (line.front() > a - m + 1 && a >= m - 1)//保证判断的时候已经到达了所判断区域的最后
		{
			mins[len] = all[line.front()];//注意让每一个判断区域都有最小值
			len++;
		}
		while (!line.empty() && line.front() <= a - m + 1)//最前元素超出判断区域将其删去
		{
			mins[len] = all[line.front()];
			len++;
			line.pop_front();
		}
	}
//	while (len < n - -m)
//	{
//		mins[len] = all[line.front()];
//		len++;
//	}
	//
	while (!line.empty())
		line.pop_back();
	len = 0;
	for (int a = 0; a < n; a++)
	{
		if (line.empty())
			line.push_back(a);
		else
		{
			if (all[a] < all[line.back()])
				line.push_back(a);
			else
			{
				while (!line.empty() && all[a] >= all[line.back()])
				{
					line.pop_back();
				}
				line.push_back(a);
			}
		}
		if (line.front() > a - m + 1 && a >= m - 1)
		{
			maxs[len] = all[line.front()];
			len++;
		}
		while (!line.empty() && line.front() <= a - m + 1)
		{
			maxs[len] = all[line.front()];
			len++;
			line.pop_front();
		}
	}
	//
	for (int a = 0; a < len; a++)
	{
		printf("%d", mins[a]);
		if (a != len - 1)
			printf(" ");
		else
			printf("\n");
	}
	for (int a = 0; a < len; a++)
	{
		printf("%d", maxs[a]);
		if (a != len - 1)
			printf(" ");
		else
			printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值