A1010 Radix (25分)【C语言】

A1010 Radix (25分)【C语言】

原题链接

题目描述:
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​ , your task is to find the radix of one number while that of the other is given.

输入格式:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

输出格式:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

输入样例1:

6 110 1 10

输出样例1:

2

输入样例2:

1 ab 1 2

输出样例2:

Impossible

实现代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
LL Map[256]; //0~9, a~z 与 0~35 对应
LL inf = (1LL <<63) - 1; //long long的最大值2^63-1

char N1[20], N2[20], temp[20];
int tag, radix;

void init(){ //初始化Map 
	for(char c='0'; c<='9'; ++c){
		Map[c] = c - '0';
	}
	for(char c='a'; c<='z'; ++c){
		Map[c] = c - 'a' + 10;
	}
}

LL convertNum10(char a[], LL radix, LL t){ //将a转化为10进制,t为上界 
	LL ans = 0;
	int len = strlen(a);
	for(int i=0; i<len; ++i){
		ans = ans * radix + Map[a[i]];
		if(ans<0 || ans>t) return -1;
	}
	return ans;
}

int cmp(char N2[], LL radix, LL t){ //N2的十进制与N1的十进制进行比较 
	int len = strlen(N2);
	LL num = convertNum10(N2, radix, t);
	if(num<0) return 1; //N2溢出,故N2较大 
	if(t>num) return -1; //N1较大 
	else if(t==num) return 0; //N1,N2一样大 
	else return 1; //N2较大 
}

LL binarySearch(char N2[], LL left, LL right, LL t){ //二分法求解N2的进制 
	LL mid;
	while(left<=right){
		mid = (left+right)/2;
		int flag = cmp(N2, mid, t);
		if(flag==0) return mid;
		else if(flag==-1) left=mid+1; //N1较大,N2的进制需要变大,往右区间查找 
		else right=mid-1; //N2较大,N2的进制要减小,往左区间查找 
	}
	return -1;
}

int findLargestDigit(char N2[]){ //寻找N2最大数位,则N2进制的最小进制为最大数位+1 
	int ans=-1, len=strlen(N2);
	for(int i=0; i<len; ++i){
		if(Map[N2[i]]>ans){
			ans = Map[N2[i]];
		}
	}
	return ans+1;
}


int main()
{
	init();
	scanf("%s%s%d%d", N1, N2, &tag, &radix);
	if(tag==2){
		strcpy(temp, N1);
		strcpy(N1, N2);
		strcpy(N2, temp);
	}
	LL t = convertNum10(N1, radix, inf); //将N1从radix进制转为10进制
	LL low = findLargestDigit(N2); //N2进制的最小值 
	LL high = max(low, t) + 1; //N2进制的最大值 
	LL ans = binarySearch(N2, low, high, t);
	if(ans==-1) printf("Impossible\n");
	else printf("%lld\n", ans);
	
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值