573 - The Snail

  The Snail 

A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% $\times$ 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.

DayInitial HeightDistance ClimbedHeight After ClimbingHeight After Sliding
10'3'3'2'
22'2.7'4.7'3.7'
33.7'2.4'6.1'-

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.

Input 

The input file contains one or more test cases, each on a line by itself. Each line contains four integers H U D , and  F , separated by a single space. If  H  = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive.  H  is the height of the well in feet,  U  is the distance in feet that the snail can climb during the day,  D  is the distance in feet that the snail slides down during the night, and  F  is the fatigue factor expressed as a percentage. The snail  never  climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides  D  feet at night.

Output 


For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.

Sample Input 

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output 

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2


这道题是说 一只蜗牛,每次白天向上爬U米,晚上会下滑D米,而且第二天爬的高度会比前一天少了U*F%。这个减少的幅度不变,直到最后小于0之后,就不在爬,只等着下滑。

我刚开始理解错了,以为蜗牛向上爬的高度小于0之后,会休息一天,然后又满血复活。。。结果不对。悲剧的是,样例得到的答案竟然一模一样!!!怎么也找不出错来

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main ()
{
    int h,u,d,f,day,p;
    double sum,jian,shang;
    while(cin>>h>>u>>d>>f)
    {
        sum=0;
        shang=u;
        if (h==0) break;
        jian=u*f*1.0/100;
        p=0;
        day=0;
        while(1)
        {
            day++;
            sum+=shang;
            if (sum>h) break;
            sum-=d;
            if (sum<0) break;
            shang-=jian;
            if (shang<0)
            {
                shang=0;
            }
        }
        if (sum>h) printf("success on day %d\n",day);
        else printf("failure on day %d\n",day);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值