673 - Parentheses Balance

13 篇文章 0 订阅

  Parentheses Balance 

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct,  (A ) and  [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer  n  and a sequence of  n  strings of parentheses  ()  and  [] , one string a line.

Output 

A sequence of  Yes  or  No  on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes
 

题意:给一堆括号,让你判断是否能够组合

就是简单的栈的利用,把左半边的括号入栈,遇到右半边与其匹配。不过要注意到最后要判断是否为空栈。还有就是字符串当中可能有空格。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<stack>
#include<cstring>
using namespace std;
int main ()
{
    int n,len,i;
    char str[130],temp;
    cin>>n;
    getchar();
    while(n--)
    {
        bool flag=true;
        stack<char> s;
        gets(str);
        len=strlen(str);
        for (i=0; i<len; i++)
            if (str[i]==' ') ;
            else
            {
                if (!flag) break;
                if (str[i]=='(' || str[i]=='[') s.push(str[i]);
                else
                {
                    if (s.empty())
                    {
                        flag=false;
                        break;
                    }
                    else
                    {
                        temp=s.top();
                        s.pop();
                        if ((str[i]==')' && temp=='(') || (str[i]==']' && temp=='[' ) ) ;
                        else
                        {
                            flag=false;
                            break;
                        }
                    }
                }
            }
        if (!s.empty()) flag=false;
        if (flag) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值