(POJ 1840)Eqs 哈希表

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 15893 Accepted: 7799
Description

Consider equations having the following form:
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.
Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output

The output will contain on the first line the number of the solutions for the given equation.
Sample Input

37 29 41 43 47
Sample Output

654
Source

Romania OI 2002

题意:
a1x1^3+ a2x2^3+ a3x3^3+ a4x4^3+ a5x5^3=0
对于这个等式,给出了a1到a5,最后求有多少组X1—X5满足这个等式,其中所有的Xi都是不能等于0的。

分析:
对于直接暴力时间复杂度为100^5,超时了。
我们可以将x1,x2,x3,x4,x5分为两部分,相求x1,x2,x3这部分,将所有的结果值出现的次数用一个数组保存起来,然后在枚举x4,x5去将所有的结果加起来即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

char hash[25000005];//int 会超空间
int a[6];

int main()
{
    memset(hash,0,sizeof(hash));
    for(int i=1;i<=5;i++)
        scanf("%d",&a[i]);
    for(int i=-50;i<=50;i++)
    {
        if(i==0) continue;
        for(int j=-50;j<=50;j++)
        {
            if(j==0) continue;
            for(int k=-50;k<=50;k++)
            {
                if(k==0) continue;
                int tmp = i*i*i*a[1]+j*j*j*a[2]+k*k*k*a[3];
                if(tmp > 12500000 || tmp < -12500000) continue;
                hash[tmp+12500000]++;
            }
        }
    }
    int ans = 0;
    for(int i=-50;i<=50;i++)
    {
        if(i==0) continue;
        for(int j=-50;j<=50;j++)
        {
            if(j==0) continue;
            int tmp = -(i*i*i*a[4]+j*j*j*a[5]);
            ans += hash[tmp+12500000];
        }
    }
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值