POJ 3494 Largest Submatrix of All 1’s

Largest Submatrix of All 1’s

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 8390 Accepted: 3039
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

 

我们要找到的某个矩形可以转换成 以某一个行开始的 histogram的最大矩形问题。

矩形的高,要自己找。

	      /* 1. 一行一行的枚举 
		     2. 构建矩形 
		     3. 单调栈模型求最大的矩形面积。 
             G++可以过  		  
*/ 
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
using namespace std;
int   mat[2009][2009];  
int   h[2009][2009];
int   w[2009];
int   n,m;
void  init( ){
	  memset( h,0,sizeof(h));
	  for( int i=1;i<=m;i++){
	  	   for( int j=1;j<=n;j++){
	  	   	    if( mat[i][j] ==0  ){
	  	   	        h[i][j] = 0; 	
			    }
			    else h[i][j] = h[i-1][j]+1;
			 }
	  }  
	  for( int i=1;i<=m;i++)
	       h[i][n+1] = 0;
}
int   solve( int row ){
	  // 单调栈求最大矩形面积。 
	  int ans = 0;
	  memset(w,0,sizeof(w));
	  stack<int> s;
      int pos = 0;
	  for( int i=1;i<=n+1;i++){
           if( s.empty() || h[row][i] >= s.top()   ){
           	   s.push( h[row][i] );
           	   w[++pos] = 1;
		   }
		   else {
		   	   int width = 0;
			   while( !s.empty()  && s.top() >= h[row][i] ){
			   	      width+=w[pos];
			   	      ans = max( ans , s.top() * width );
			   	      s.pop();
			   	      pos--;
			   }
			   s.push( h[row][i]);
			   w[++pos] = width + 1;   
		   }  
	  } 	  
	  return ans ;  
}
int   main(void){
	 
      while( scanf("%d%d",&m,&n)!=EOF ){
		   for( int i=1;i<=m;i++){
		   	    for( int j=1;j<=n;j++){
		   	    	  scanf("%d",&mat[i][j]);
				   }
		   }
		   
		   init();//构建矩形。 
		   int ans = 0;
		   for( int i= m;i>=1;i-- ){ // 一行一行枚举 
		   	    ans = max( ans , solve(i) ); // 单调栈求最大矩形面积。 
		   } 
		   printf("%d\n",ans);
	}
	
	
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值