HDU 5914 Triangle(规律+斐波那契数列)

Triangle

Problem Description

Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.

Input

The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).

Output

For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.

Sample Input
3
4
5
6
Sample Output
Case #1: 1
Case #2: 1
Case #3: 2
Source

2016中国大学生程序设计竞赛(长春)-重现赛

题意:

有n根木棍,长度分别为1、2、3…n的木棍,计算至少去掉几根木棍使得剩下的木棒不能构成三角形。

思路:

三角形形成的条件:两边之和大于第三边,我们可以找出边界条件,即两边之和等于第三边,这时我们可以想到斐波那契数列。斐波那契数列的话,那么就不能组成三角形。

1 2 3 5 8 13 21

所以此题,就可以找把除斐波那契数的去掉即可。

AC代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 100;
int F[maxn];
int main()
{
    int n;
    cin >> n;
    F[0] = 1;
    F[1] = 2;
    int tot = 2;
    for(int i = 2; F[i] <= 20; i++) {
        F[tot++] = F[i-1] + F[i-2];
    }
    for(int i = 1; i <= n; i++) {
        int t;
        cin >> t;
        if(t<=3) {
            printf("Case #%d: %d\n", i, 0);
        }
        else {
            int ans =  0;
            for(int j = 0; F[j] <= t; j++) {
                ans++;
            }
            printf("Case #%d: %d\n", i, t-ans);
        }
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值