UVa 11995 I Can Guess the Data Structure!

42 篇文章 0 订阅
32 篇文章 0 订阅

There is a bag-like data structure, supporting two operations:1 x Throw an element x into the bag.2 Take out an element from the bag.Given a sequence of operations with return values, you’re going to guess the data structure. It isa stack (Last-In, First-Out), a queue (First-In, First-Out), a priority-queue (Always take out largerelements first) or something else that you can hardly imagine!InputThere are several test cases. Each test case begins with a line containing a single integer n (1 ≤ n ≤1000). Each of the next n lines is either a type-1 command, or an integer 2 followed by an integer x.That means after executing a type-2 command, we get an element x without error. The value of xis always a positive integer not larger than 100. 

The input is terminated by end-of-file (EOF).

Output

For each test case, output one of the following:

stack It’s definitely a stack.

queue It’s definitely a queue.

priority queue It’s definitely a priority queue.

impossible It can’t be a stack, a queue or a priority queue.

not sure It can be more than one of the three data structures mentionedabove.

Sample Input

61 11 21 32 12 22 361 11 21 32 32 22 121 12 241 21 12 12 271 21 51 11 32 51 42 4

Sample Output

queue

not sure

impossible

stack

priority queue

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

stl+模拟~

直接套stl~


#include<cstdio>
#include<stack>
#include<queue>
using namespace std;

int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int x,y,k1=0,k2=0,k3=0;
		stack<int> sta;
		queue<int> q;
		priority_queue<int> dui;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&x,&y);
			if(x==1)
			{
				sta.push(y);q.push(y);dui.push(y);continue;
			}
			if(sta.empty() || sta.top()!=y) k1=1;
			if(q.empty() || q.front()!=y) k2=1;
			if(dui.empty() || dui.top()!=y) k3=1;
			sta.pop();q.pop();dui.pop();
		}
		if(!k1 && k2 && k3) printf("stack\n");
		else if(k1 && !k2 && k3) printf("queue\n");
		else if(k1 && k2 && !k3) printf("priority queue\n");
		else if(k1 && k2 && k3) printf("impossible\n");
		else printf("not sure\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值