PAT甲级1002

题目:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题意:给出两个多项式,求它们的和

思路:用map储存多项式,然后遍历一遍一个一个求和

#include<iostream>
#include<map>
using namespace std;
int main()
{
    int n,k,tmp1;
    double tmp2;
    map<int,double,greater<int>> m1,m2,ans;//建立指数--系数的对应关系
    //m1,m2分别表示一个多项式
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>tmp1>>tmp2;
        m1[tmp1]=tmp2;
    }
    cin>>k;
    for(int i=0;i<k;i++)
    {
        cin>>tmp1>>tmp2;
        m2[tmp1]=tmp2;
    }
    //类似双指针,遍历一遍
    auto p1=m1.begin();
    auto p2=m2.begin();
    while(p1!=m1.end() && p2!=m2.end())
    {
        if(p1->first==p2->first)//指数相等直接相加
        {
            ans[p1->first]=p1->second+p2->second;
            ++p1;
            ++p2;
        }
        else if(p1->first>p2->first)
        {
            ans[p1->first]=p1->second;
            ++p1;
        }
        else
        {
            ans[p2->first]=p2->second;
            ++p2;
        }
    }
    //当一个多项式遍历到结束时,另一个还没遍历完,将另一个直接放入结果中
    while(p1!=m1.end())
    {
        ans[p1->first]=p1->second;
        ++p1;
    }
    while(p2!=m2.end())
    {
        ans[p2->first]=p2->second;
        ++p2;
    }
    int cnt=0;//统计非零系数个数;
    for(auto it=ans.begin();it!=ans.end();it++)
        if(it->second!=0)
            ++cnt;
    cout<<cnt;
    for(auto it=ans.begin();it!=ans.end();it++)
        if(it->second!=0)
            printf(" %d %.1lf",it->first,it->second);
    system("pause");      
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值