zzuli:1066字符分类统计

题目描述

输入一行字符,以回车符作为输入结束的标志。统计其中英文字母、数字字符和其他字符的个数。

输入

多个字符,以回车符结束,回车符不作为有效字符。有效字符个数不超过100。

输出

输出分3行,格式见输出样例。

样例输入 Copy

Abse 4+5*3=?

样例输出 Copy

letter:4
digit:3
other:5
#include <stdio.h>
int main()
{
	char ch;
	int letter=0,digit=0,other=0;
	while(scanf("%c",&ch),ch!='\n')
	{
		if(ch>='a'&&ch<='z'||ch>='A'&&ch<='Z')
		{
			letter++;
		}
		else if(ch>='0'&&ch<='9')
		{
			digit++;
		}
		else
		{
			other++;
		}
	}
	printf("letter:%d\ndigit:%d\nother:%d\n",letter,digit,other);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值